2

I am not able to get the jeep to the auto parts and get it's diagnostic but I'm wondering if the coil pack could be my problem? I've tried to deduce the misfire for days and have read and tried numerous adjustments, but cannot get the motor to advance and run smooth.

I have a newly rebuilt 89 XJ 4.0L inline 6 cylinder in my 91 Wrangler. I'm still trying to work out the misfire problem. It's never been driven more than a couple blocks. It will idle okay, but to drive it I keep having the backfire in the exhaust when I accelerate.

One thing I'm unsure of is the coil: is it okay to have it mounted to a metal fabricated mount or does it need to be grounded directly to the block? It is wired to alt. and starter could they be wired backwards by chance?

Also, I read the PCM needs to be reset at the dealer if I used the brain that was originally on my Wrangler motor? It seems like the timing is off and it is in the correct firing order. I tried the one tooth forward and back etc.

It does now start and idle at least, but I can still hear a miss in it and something is not right. Could the coil be going bad and fouling the spark plugs?

1

If the coil is firing at all, there shouldn't be an issue.

Carefully double check your spark plug wire locations (firing order). It would be very easy to have them in the wrong locations. Check each spark plug wire from the cap all the way to the plug; don't assume it's going to the right place, ensure it is. This would lead to what you're describing almost exactly. Here is the firing order for the 4.0L I6 engine for you:

enter image description here

Also, you can check to ensure your vacuum advance is connected to the right source (should be to a vacuum source above/before the throttle plates) and the vacuum advance is working. You can disconnect the vacuum advance (plugging the hose after disconnect so no loss of engine vacuum) to see if there is any difference in how it runs. If you have a device to provide vacuum, you can attempt to provide it to the advance. It should change how the engine runs when you apply vacuum. If you don't have a vacuum pump or whatever, you can just suck on the vacuum hose, which should give you enough change to tell if the advance is working at all. This should be done at idle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.