Questions tagged [regal]

The tag has no usage guidance.

7 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3 votes
0 answers
494 views

2000 Buick Regal Heater/Air Malfunctioning

Background I have a 2000 Buick Regal. The Heater/Air Conditioner runs erratically. Sometimes when set for air conditioning it will blow hot air out on both passenger and driver sides, sometimes ...
Jack's user avatar
  • 31
1 vote
0 answers
33 views

What USB speed in 2019 Buick Regal?

What data speed does the 2019 Buick Regal TourX have on its USB-A data ports? For example, USB 2.0, 3.0, 3.1, or 3.2? There's no mention of a speed or USB spec in the Getting to Know guide, ...
Merchako's user avatar
  • 111
1 vote
0 answers
212 views

2000 Buick Regal GS Key fob Half Paired

I drive a 2000 Buick Regal, and all of a sudden both key fobs I had paired stopped working. I have tried going through the pairing procedure again, but it never works. While pairing, after holding ...
Alexander M's user avatar
1 vote
0 answers
763 views

Help! Too much pressure in cooling system

So I have a 1980 Buick regal with a Pontiac 265 v8 mated to a th200.. I am having issues with the cooling system. I have replaced a dozen thermostats and 3 radiators. and 3 aftermarket coolant temp ...
Chris Benner's user avatar
0 votes
0 answers
25 views

Why is my car wont start

My mechanic changed my ecm and programmed it to my 2001 buick regal he programmed both sets of keys i have now all of a sudden car will crank but wont start also battery keep draining. Before he ...
Donna Beal's user avatar
0 votes
0 answers
30 views

2001 Buick Regal LS 3.8L - Cannot identify two wire connector near alternator

What is the two wire connector located in the upper left side of the picture below (near alternator with blue band) for a 2001 Buick Regal LS 3.8L 3800 Series II? It is about three inches long. The ...
user2514157's user avatar
0 votes
0 answers
496 views

Hard Starting only when warm - getting camshaft position sensor codes, but have replaced them

Have a 2012 Buick Regal Ecotec 2.4 with 95K miles. Had engine light with PO340 code to replace camshaft position sensor. Was getting no drive-ability issues at the time, but replaced sensors. After a ...
yahootanker's user avatar