3

Background

I have a 2000 Buick Regal.

The Heater/Air Conditioner runs erratically. Sometimes when set for air conditioning it will blow hot air out on both passenger and driver sides, sometimes hot air on one side and cold air on the other side, and sometimes it will run just perfectly. Same thing when on the heat setting, sometimes blows cold air on both sides, sometimes cold on one side and hot on the other side, and sometimes runs just perfectly. I have had it back to the dealer several times and they have replaced the entire unit in the dashboard, but weeks later the problem just reappears.

Question

Does anyone have any suggestions as to what might be going on and what might be done to fix the problem?

  • Hot air on all settings, both sides suggests a vacuum problem or a problem with the electronic vacuum switching valve under the dash. I'd suspect the problem lies there. What exactly did the dealer replace? The HVAC controls? – Ben Jul 12 '16 at 22:03
  • Thanks for the insight, Ben. I will check those items out. Yes, the dealer replaced the entire HVAC unit in the dashboard several times. – user19752 Jul 13 '16 at 12:13
  • Per OP: Thanks for the insight, @Ben I will check those items out. Yes, the dealer replaced the entire HVAC unit in the dashboard several times. – MooseLucifer Jul 13 '16 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.