3

I have a Audi A4 B8 2009 model. I am running with a very stupid problem causing a great amount of pain.

So, just a few weeks back, the "front hood (bonnet) is open" indication started showing up on the dashboard, even when the hood is shut. Now when the car is stationary or moving at a very slow speed, the wipers cease to work. Only way it works when the car is in motion (20+ kmph), the wipers will work and that too only when I press the wipe once option. This could cause a potential disaster if it rains heavily.

From my understanding, it looks like there is some mechanism in the car, wherein the wiper doesn't work if the hood is open. In this case, since the sesnor is indicating the hood is open when its actually shut, it doesn't let the wipers work. And secondly, when at speeds it probably has another fail safe mechanism to activate the wipers.

Questions:

1. Before I get the sesnor/switch replaced, does anyone know how to remove the switch temporary?

2. Is there any VAGCOM OBD-2 codes that can disable the hood lock warning sign on the dashboard (the warning is not a indicator by itself, it just shows a red color on the hood part of the car logo on dashboard.

Thanks in advance.

1

It is very common on these models for the hood switch to fall out of the catch.

If you look at the catch there will be a micro switch that will either be hanging by its wire or faulty.

If it's come loose just reattach it, you'll have to remove the catch and slide the two 'nibs' on the switch into the holes on the rear of the catch.

I'm not sure if you can buy the switch separately but you can just join the wires to fool the computer that the hood is shut. Cut the wires on the switch side of the plug so you don't have to join any wires if you ever replace the switch.

  • if you join the two wires that is normally "on" ie hood open, for closed they should not be connected at least in most cases... – Solar Mike Oct 6 '17 at 9:30
  • @SolarMike - i should imagine it'd be the other way round. things like hoods will likely be designed to fail "Safe" - I.E. the safest readout will be shown. In the case of a hood, an open hood is very dangerous, so for this reason i should imagine that most will read no current flow as "open". If a switch were to fail and show the hood as closed no matter what, this could cause serious issues. – Miller86 Oct 6 '17 at 13:30
  • electrically based safety circuits are relatively "new" on cars - just look at some of the legislation that occurs after accidents etc Prior to circuits to detect "hood open" were switches fitted to control under-hood lights (also fed by the side or marker lights) so one could see the engine at night. One of the main reasons for fitting a "hood open" circuit is to prevent damage of the wipers hitting the hood when it is open - usually due to the driver getting out of the car to look under the hood and "forgetting" the wipers are on.... – Solar Mike Oct 6 '17 at 13:37
1

You don't need to remove the switch to get rid of the warning, you just have to disconnect it. On some models A4 the detector is part of the latch mechanism, on others (depending on model year) it's on a separate push-in catch near the latch. You can see a cable going to it with a modular connector. Simply pull the connector apart and secure the ends so they can't get sucked into anything. I don't think you need to jump across the wires to get the light to stop, so try it without wiring them together first.

If it's a separate switch from the latch it may be that the switch has just come out, or maybe the plastic bracket that retains it has broken. You may be able to just pop it back in.

I don't think that the wipers are in any way connected to the hood sensor, on my A4 I ran the wipers with the hood open several times on all settings. I think you have a separate issue there, possibly the selector mechanism, although that wouldn't explain the in motion thing. Maybe it's a relay, I'd check the simple things first.

0

I had a similar issue with a Ford Focus. I know - different brand, but bear with me.

The issue was that the bonnet (Hood in US English) catch was working fine, but that the switch that detected if it was on or off was poorly waterproofed and shorting. Rather than replace the bonnet catch and sensor (a bit of a job, which i've been told is a nightmare in that particular focus model because the bonnet release is really hard to seat accurately) I simply bridged the switch.

I took a 2 inch piece of electricians wire, removed the plug going into the unit from the electrics, inserted one end into each terminal, and electrical-taped the crap out of it for waterproofing. Several months on it still reads as "shut". I've checked it a few times, to ensure that it's not charring or burning, but it seems fine so far so am planning on leaving it as a longer-term fix. I plan on running this car into the ground, so I'm unconcerned about resale.

Now, dependant on your model of vehicle this may or may not work for you, but if the switch setup is the same (I.e. simple current flow = shut, no current = open). I also counsel caution because I don't know how this would affect the electrics, but it's worked for me on a 2005 focus so far.

I agree with others in this, in that it sounds odd that the wipers are linked into the bonnet catch. This might be a good way to test that out.

0

I had the same problem on my A3. Hood sensor was flashing on the dash. Couldn't set the alarm. Wipers wouldn't work unless moving. I tried cleaning the sensor but it didn't work. So I cut the wires going into the sensor and capped them with electrical tape. Didn't cross them. Now the hood sensor is off. Wipers work. Alarm sets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.