6

My poor Saab 900 is having touble getting going. I was away for about a month, and got the oil changed before I left. When I came back, I drove the car to my grandmother's and back, about 15 minutes each way, and it ran fine. The next day, it stalled right after starting.

When I try to start the car, it revs to about 1400rpm as usual, but drops slowly to 0 instead of settling at the standard 800rpm idle. On subsequent attempts, it stalls out much quicker. If I let the car sit overnight and try again, the rpms die a little slower on the first try.

Intake

The throttle body is clean and the butterfly valve doesn't stick. I looked for vacuum leaks but saw nothing obvious. (Not sure how to check thoroughly without a running engine.) The air filter is clean too, to be sure.

Idle air control

I cleaned and oiled the IAC valve. When I turn the assembly quickly in my hand, I can feel the rotor turning easily inside. That's not supposed to have a return spring, right? If not, it seems to rotate freely. Also, the voltage across the contacts jumps when I turn it, so I figure it's working according to Faraday's Law. It also shows a steady resistance across its contacts. One wire to the IAC is grounded and another is getting 12v.

Throttle position sensor

Same thing for the TPS. The resistance across the TPS changes smoothly when I open and close the valve.

Mass air flow sensor

The MAF appears clean, but I wiped off the contact anyway. Not sure how to test this one. Blow across it and check for a change in resistance?

Battery

I checked that the battery (-) was properly grounded to the chassis. In this post, someone suggests that an improper ground, combined with an older battery (or one that's been sitting for a month?) can cause "a relay to drop out". How can I look into this?

Ignition

Today, I also pulled all the ignition wires and cleaned the contacts, both on the distributor and spark plug end. Some of the spark plug contacts seemed to have a little gunk on them. I also cleaned the "brushes" inside the distributor cap, which had a bit of build up on them.

After cleaning the contacts, I put everything back together and tried again. Here is a video (sorry for the lighting.) Surprisingly, on the second try, the car actually idled! I pushed my luck by touching the gas pedal, and that killed it. But considering how much better it did today (actually idled for a few seconds), I am considering replacing the ignition wires. But then what would the pedal have to do with it?

Has anyone seen anything like this? Taking suggestions.

  • A cheap OBD2 reader is invaluable in a case like this for reading the values of all the sensors, like MAF, MAP and temperature sensors to verify that they are giving valid values. – HandyHowie Feb 1 '16 at 8:23
  • You are not able to keep the engine going by revving it, it just about always dies after a couple of seconds, is that correct? – HandyHowie Feb 1 '16 at 17:48
  • That's correct. In fact, if I touch the accelerator, it dies immediately. Googling that has led me to suspect the fuel filter. That would also explain why it has an easier time starting after sitting for a while: if the filter resists the flow of fuel, the filter outlet has low pressure. Letting the car sit lets fuel slowly flow through the filter, so the outlet pressure rises. But the fuel can't flow fast enough to feed the engine, so after a few seconds, the pressure drops and the engine stalls. It's just a theory, but I will come back to report after replacing it. – Keith Feb 1 '16 at 18:11
  • OK, I took a look at the filter. Looks pretty new actually. Back to the drawing board. – Keith Feb 1 '16 at 18:41
  • 1
    Try disconnecting your MAF sensor, then start the engine, see if there is any difference. – HandyHowie Feb 1 '16 at 19:22
2

I have experienced the same symptoms on an engine, where the MAF sensor was giving lower than expected readings. The engine would only run for a few seconds before stalling. A new MAF sensor fixed the problem.

I tested my MAF on the bench with a hair dryer and a multimeter. It wasn't until I got a replacement that I could see how low a reading the faulty one was giving.

  • Uh-huh, that was it. I tried cleaning it, but that didn't help. Replaced it and all is working now. – Keith Feb 8 '16 at 19:26
  • @Keith Good news. Pleased for you. – HandyHowie Feb 8 '16 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.