7

EDIT: Awful jumble of poorly shot pictures

6/20/16 EDIT: Video

The sunroof on my 2006 Infiniti G35 Sedan will not retract (open) into the roof. It will tilt up and down without issue, and it will begin to retract, only to hit the physical limiter switch almost immediately. The motor seems to be running fine, and the clutch seems to engage without issue. I could not find similar symptoms on any of the Nissan/Infinti forums I frequent.

I removed the glass and interior sunroof cover/shade, and was able to see that the limiter switch is not moving back when the 'open' button is pressed. I am able to move the limiter switches (and the rest of the mechanism) by hand, but I have to pry a piece of the switch out of a groove in the tracks before they will budge. There does not appear to be any mechanism that should be doing that prying during normal operation, so I'm confident that is not the issue.

I am unable to turn the motor using an allen/hex key, even with the motor removed from the assembly (I put as much pressure on the 4mm key as I am willing to risk, to no avail.)

I tried the 'reset sunroof limit' procedure from Nissan/Infiniti, but it encountered the same limit switch problem. I also tried lubricating all visible tracks, pivots, and joints with silicone grease.

What could be preventing the limit switch from moving? Can anyone find detailed drawings of a Nissan sunroof system to aid in my troubleshooting? I have read there is a cable that pulls the limit switches back, but the motor is in the front, and there doesn't seem to be anything other than rails at the rear of the assembly. Pictures of the sunroof mechanism tell the same tale.

EDIT: I'm not great with wiring diagrams, could whatever leads to the 'comfort stop' on the diagram below be the problem?

EDIT AGAIN: I checked all 3 fuse boxes and couldn't find anything that said sunroof, and none of the fuse boxes seemed to correlate to the fuse diagram shown below.

6/20/16 EDIT: Finally got my roof rack off and dug into this problem again, tried a new motor from the junk yard and it hit the same problem.

Does this show what could be the problem?

This isn't important enough to sink serious money into, but it's summertime, and I want a working sunroof dammit!

EDIT: Awful jumble of poorly shot pictures

  • 3
    Good question. I have the G37 and had the same issue. I tore into deeply, could find the issue, reassembled and the....it worked. I don't know what I did to fix other than fact I'm amazing which my GF never seems to acknowledge. I hope this is helpful, but probably it's just noisy. – DucatiKiller May 28 '16 at 22:05
  • 1
    I think pictures would be useful here. Else I'd have to buy a G35 to qualify for the bounty ;) – Zaid Jun 1 '16 at 1:29
  • 2
    Here's an exploded diagram dl.dropboxusercontent.com/u/55044707/Untitled.jpg – Ben Jun 2 '16 at 20:40
  • 1
    @MooseLucifer ok, I was wondering if it might have something in there that's jamming it, but if it runs with power that's probably just the gearing making it difficult to turn (it's probably got a worm gear in it or something). Have you tried blasting the whole thing (runners, connecting rods, motor etc) with compressed air to try and loosen anything that might be jamming the smaller parts? – Aaron Lavers Jun 3 '16 at 6:45
  • 1
    @AaronLavers I have not, but I did give it a healthy coating of silicone grease, to no avail. I also checked all applicable fuses, and all were fine. I think. Like I said, I'm terrible with wiring. – MooseLucifer Jun 3 '16 at 6:47
6
+25

For starters, here is a link with all the OEM sunroof info: sunroof

I'd recommend doing the dis/re-assembly again. This time, following every instruction to the tee. Then, do the reset again following it to the tee.

Once you've done that, test it.

If it still doesn't work it would point a big finger toward the motor being bad.

Per the diagram and instructions there doesn't seem to be a physical limiter at all. I did double check this with a buddy of mine (who is a certified master mechanic with ~20 years experience) and he mentioned that these types of systems usually use motor feedback for controlling "stop" functions. Additionally, the info in the link:

The CPU of sunroof motor monitors the sunroof motor operation and the sunroof position (fully-closed or other) by the signals from the sunroof motor.

So, if going through the entire reset and ensuring that the tracks are functioning properly (meaning the rails guide slide smoothly the bit that they do move) doesn't fix the problem, then there has to be something wrong with the motor. Also, if the motor immediately stops trying to push, then it's even more likely a motor issue because if it was mechanical blockage, the motor would still try to push a little (even for 1/2 second or so).

Anyway, 18 pages of manufacturer data should be able to help I'd think!

Cheers!

  • Really nice first post. Thank you! Welcome to the site. Hope to see more from you! Cheers! – DucatiKiller Jun 3 '16 at 18:24
  • 1
    @DucatiKiller Thanks! I've been on stackoverflow for a bit now. :) I'm sure I'll be around though. – kyle_engineer Jun 3 '16 at 18:52
  • Thanks for the info. I'm reluctant to think its the motor itself, but it's worth a shot. I'll call my local scrap yard for pricing so I can at least test the theory. Next time I tear into it I'll post a video that shows the problem in action. Thanks again! – MooseLucifer Jun 5 '16 at 1:48
  • @MooseLucifer for sure. You can also try to disconnect the motors drive from the rest and test the motor with no load. If it still stops then there probably something wrong with it. That way you don't have to buy a new one for a test. – kyle_engineer Jun 5 '16 at 2:02
  • The motor had no problem running in either direction when it wasn't connected to the assembly, and the physical limits are spring loaded, so the springs provide the load telling the motor to stop. – MooseLucifer Jun 5 '16 at 2:08
2

I finally got the thing working again. Long story short: there was a piece of plastic jammed under one of the carriers that holds the glass.

Long story long:

After a couple recent trips to and from the junkyard, pulling a sunroof apart, returning home to work on mine, coming up with new theories on what was broken, and bolting everything up to return to the junkyard, I ended up with a full, complete, comprehensive, and extensive understanding of this particular Nissan sunroof. Seriously, if anybody ever has a question about sunroofs, and it even remotely resembles the Nissan one, I can probably answer your question.

Anyways, I got to the point where, as I had always suspected, I now knew that my sunroof was doing everything it was supposed to UNTIL it hit those spring loaded 'limit' switches (as I had previously referred to them as). I ended up observing that when the system was powered, one 'limit' switch would travel half way before stopping (shown in video), while the other would travel .100" less.

I also found that the statement in my original question about the clips that prevent the assembly from sliding back having no "mechanism that should be doing that prying during normal operation" was completely wrong. There were little pieces of plastic on the bottom of the carriers that served to lift that clip out of the rail, but only once the spring was fully compressed. I also noted that on the side where the spring was not being traveled as far, the clip was being pushed down into the track, whereas on the other side the clip did not move at all, and if working properly the clip should be pulled out of the track.

I couldn't see an obstruction but I figured it was some hardened grease or other contaminants causing those symptoms. I was eventually able to pry the obstruction out using a 90° bent type feeler gauge. It was a piece of plastic that, ironically, had come from a piece of the sunroof shade that had broken off before I took possession of the car. When I bought it, the shade had come off its track and jammed, and the previous owner attempting to move it had broken a pair of the little 'feet' that keeps the shade on its track (of which the shade has 4 clips, each with 2 feet). When initially detailing the car and buying a new clip (from the very junkyard car that helped me solve the problem), I had found one of the broken clips under the seat, and didn't even think twice about where the second clip had gone.

So, yeah, I finally fixed this problem after $1.00, 5 months and 20+ disassembles, just time time for the rainy season. I made sure to reinstall the glass with fresh 'new' bolts I had pulled from the junkyard car (hence the $1), knowing that eventually I would get to use them for the last time. Poetic, I know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.