0

I have a 2013 Nissan Rogue with the in-dash entertainment system (not the new connect system). Since I updated my iPhone to iOS 8.1, the USB audio hasn't connected reliably. When I first updated to 8.1.1, it worked for one afternoon, but then it went back to either not connecting at all or connecting for about a second before showing an error on the car screen and disconnecting.

Does anyone know if it's possible to fix this via a firmware update? Can you even update the car audio firmware on an old Nissan?

4

Had the same issue with my Nissan Rogue 2011.

This listed below will fix it...

1) Go to General > Restrictions > Carplay -- Make sure Carplay is DISABLED. (The new IOS 8 enables this on default)

2) Go to General > Reset > Reset Network Settings

Apple's stupid Carplay feature nearly ruined everything. Disable it and it will work flawlessly again with bluetooth and USB music. You're welcome.

  • Is the reset network settings really necessary? That's kinda a pain to type in all of the wifi networks saved in there again. – Wesley Bland Dec 4 '14 at 22:25
  • Yes. It's necessary if you want it to work with your car. Disable Carplay first though. – Chris Dec 4 '14 at 22:27
  • Did this Work? My Iphone doesn't have the Carplay under the Restrictions menu? I have the 5c with IOS 8.1.1 – user7712 Dec 5 '14 at 14:34
  • Look again... CarPlay is on iPhone 5, 5c, 5s, 6, and 6 plus. apple.com/ios/carplay By the way, been using my iPhone 6 non-stop in my Nissan Rogue since this fix. No issues at all now. – Chris Dec 5 '14 at 16:00
  • Ok. I just upgraded to ios 8.1.3 and lo and behold... my nissan rogue stereo is working fine with it. Did Apple fix it? Not sure. – user9275 Jan 30 '15 at 18:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.