Skip to main content

Questions tagged [envoy]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
0 answers
24 views

PCM blew while on fwy. Now blows 1 second after starting

2004 gmc envoy XUV 4.2 Running perfect with NO CODES then PCM-1 fuse blew at 70mph. I replaced fuse, started vehicle, it runs for ONE SECOND and blows the PCM-1 fuse again.
shane's user avatar
  • 11
4 votes
1 answer
213 views

Correct placement of an aftermarket transmission cooler

I previously installed an aftermarket transmission cooler in a 2006 GMC Envoy (4.2, 4L60E). I installed it "after" the factory oil-water heat exchanger built into the radiator (that is, the ...
masospaghetti's user avatar
3 votes
2 answers
4k views

02' GMC Envoy. Engine KNOCK, not rod knock

I have a 2002 GMC Envoy. Last year it developed a knocking that was at a very low volume but became louder in a 2 week span. After that it's been the same, it's louder when the engine starts cold and ...
Omar Gonzalez's user avatar
6 votes
1 answer
647 views

What is causing this slight vibration?

I have a 2004 GMC Envoy 4WD with a clean title, 54k miles. Very good condition. I recently purchased my second set of tires, Pirelli Scorpion ATRs. They are solid and quiet, but after changing them ...
Aleksei's user avatar
  • 61
7 votes
1 answer
916 views

My car will not start after being driven fine

I have a 2003 gmc envoy xl it has been running fine..drove it all day. Went home 4 hrs later it will not start.. It acts like it is dead but everything from the lights to the heat works fine..I mean ...
Angela's user avatar
  • 71