Linked Questions

3
votes
1answer
458 views

O2 Sensor on 2005 VW Jetta [duplicate]

I've purchased a Bosch premium O2 sensor kit with SmartLink. It comes with a wiring chart but I have 2 wires that are not on it. My original O2 sensor has a red and yellow wire along with gray and ...
0
votes
2answers
122 views

Honda Civic O2 Sensor [duplicate]

Bought 02 upstream air fuel for 04 Honda Civic it came with a male connector while the old has a female connector the connector on the car is male so I cut the connector off the new sensor how do I ...
6
votes
2answers
15k views

How to Identify which O2 sensor is faulty WITHOUT readings from the car's system

I have a 2005 Hyundai Accent, and the check engine light is on. I'm almost 100% sure it's the O2 sensor because it's not as fuel efficient as usual... My work schedule conflicts with mechanics around ...
11
votes
2answers
13k views

My Ignition Timing is Retarded, no seriously, it's really screwed up

I logged some test data to try and help me figure out why my 98 Mazda 626 GF 2L ATX has a rough idle and is suffering from hesitation. (Speed k/h),(TPS_v),(MAF g/sec),(RPM),(SparkAdvance),(EngineLoad)...
8
votes
3answers
7k views

Shouldn't my post-cat O2 sensors (lambda probes) be reporting varying numbers?

On my 2002 BMW E46 330Ci, I've been getting error codes 202 Lambda regulating limit Bank1 and 203 Lambda regulating limit Bank2. Here's the angry sensor readings from the INPA software: I understand ...
4
votes
2answers
2k views

Trouble rewiring O2 sensor harness after dogs ate it

This is a 2005 GMC Yukon 4x4 4.8 L. Ok, dogs actually ate my harness going to Bank 2 Sensor 1 O2 sensor. The connector from the body side of the wiring is completely gone. I found a connector I can ...
5
votes
2answers
319 views

Varying acceleration while riding

My motorcycle, a KTM Duke 200, while riding is producing varying acceleration. This is during a single ride. For about a few minutes, the acceleration is alright, then after a few minutes, the ...
2
votes
2answers
434 views

2004 Mazda 3 stalls and bogs down on cold starts

So my 2004 Mazda 3 (JDM 1.5L model) stalls and hesitates during acceleration after a cold start. However, It runs perfectly after 7-10 minutes of idling. The only error code I have is for an upstream ...
4
votes
4answers
668 views

P0171: what to look at next, after MAF, O2 senors, fuel filter, and vacuum?

I have been chasing a P0171 on a project vehicle for quite some time now. This is a 1999 4Runner with the 5VZ V6 engine, 70K miles, naturally aspirated. For this particular model-year there was no ...
4
votes
2answers
107 views

Slightly low MPG - need help with my checklist

I own a '91 Ford Sierra 2.0 8V SOHC. Fairly simple engine, utilizes a Bosch L-jetronic fuel injection system. (EFI has following components: MAF, MAP, TPS, IAC, narrow-band o2 sensor, TFI module for ...
2
votes
3answers
149 views

Matching up connections on O2 Sensor for 2001 Honda Accord

I purchased a new O2 Sensor for my 2001 Honda Accord and I cannot understand why it has a female plug and not a male plug as the existing one has so I assume I have to move the wires from the new unit ...
1
vote
2answers
61 views

How can I swap wires/pins on generic aftermarket O2 sensors?

I purchased some generic aftermarket O2 sensors for my 2002 Land Rover Discovery 2, which were significantly cheaper than the "official" Land Rover replacement parts. Unfortunately after installation,...