1

While changing the rear brakes on my 2015 Audi S3, I manually retracted the piston on the right calliper (using the tool made for that purpose) and installed the new pads, but then I found out that since I have an electronic e-brake, I should be using VCDS to retract them. So for the left side I took the calliper off and then initiated the "start lining change mode" to retract the piston. I heard a motor in the brake engaging, but the piston didn't retract. I thought maybe I could get it to come out to see if it's seized, so I initiated the "end lining change mode" to push it back out. I thought it would stop by itself, but it didn't and the piston came all the way out of its seating (but stayed in the rubber boot) and a few drops of brake fluid came out of the boot surrounding the piston.

I was able to screw it back in by hand and then use the tool to manually retract it as far as it would go, but when I tried to initiate the "lining change mode" again, VCDS said something like "aborted due to malfunction". The start or end functions for the "lining change mode" both gave the same error. I thought that it might have to be reset to get rid of that error, so I initiated a factory reset on the ABS module. Unfortunately, that did more harm than good, and now I have all sorts of lights on my dash. Oh and the "lining change mode" functions still give the malfunction error.

I scanned for diagnostic codes (see output here) and there are some about ABS coding, but also a bunch that aren't related to the brakes (e.g. transmission faults). Any thoughts on how to solve this? Did I really mess things up with the ABS factory reset?

0

You must log in to answer this question.

Browse other questions tagged .