1

I have a 2013 ford focus. 146k+ miles. With all my cars, I would fill up when I hit 1/4th tank. For the last 10 months I’ve been broke and my gas tank is always under 1/4 tank and gas light on and I’ve run out of gas 3 times. 6 days ago I filled up my tank and used a gas treatment. When I started my car it immediately stalled. I had to start it 4 times before I was able to hold the gas pedal in the right spot to rev the engine. All of this was about 3 minutes. After I drove at least 7 times, I had no issues. Sunday my tank was at around 5/8 tank. I filled it up and the exact same thing happened again. So far I have driven at least 5 times, no cranking issues. Can driving for that long constantly on empty cause problems? My check engine light has been on before this happened. It’s reading as O2 sensor. There is nothing else wrong with my car. Thanks for your help.

3
  • The O2 sensor may be the reason for hard starting if its the precat one in the exhaust manifold. What's the actual error code? There may be other issues; worn spark plugs, fuel filter never replaced@100k miles, possibly worn fuel pump.
    – F Dryer
    Oct 17, 2023 at 4:50
  • Thanks. There is one error code on my car. It’s for the o2 sensor.
    – Denise M
    Dec 12, 2023 at 8:28
  • What is the code?
    – F Dryer
    Dec 12, 2023 at 9:39

1 Answer 1

0

The EVAP purge valve may be stuck. It prevents fumes from entering the engine while filling up. And\or the charcoal canister which absorbs fumes when filling up could be saturated or faulty.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .