1

I have a Cub Cadet RZT 50 Ride - on Mower.

I am having issues with the PTO clutch (magnetic clutch which engages the belt driving the mowing table under the footrest).

I have tried engaging it with a spare battery directly, and that worked so I measured the voltage at the plug which (when you are sitting on it) can be engaged by pulling on a switch. That measures 12v, so the correct voltage is getting down there, but I assume not enough amps.

I also noted that the fuse holder had melted (the plastic - not the metal) ther was a 20A fuse in there when I got it, so I replaced it with a similar one. Should that have an impact on the clutch not engaging?

Edit: further inverstigation

I did some further checks of the electrics: (uploaded a video) the indicators for clutch engaged and parking break not engaged work as expected. But measuring the voltage while fiddling with the different contacts are all over the place.

The 12v I measured earlier dropped as low as 4v and my auto-sensing voltmeter even thought it was ac instead of dc... I assume that the fuse is not the issue...

Mower PTO Clutch Model

5
  • Did you mean a 20 Amp fuse? Fuses aren't measured in Ohms. And did you check the original fuse to see if it was good? Usually if there is melted plastic in the area of electrical, it means that circuit is drawing too much amperage during usage. Commented May 14, 2023 at 12:38
  • I got it second hand. I replaced the fuse with the same amperage. The manual is quite unhelpful and just says "fuse". But if it was the fuse that was defective, it wouldn't start at all AFAIK.
    – JoSSte
    Commented May 14, 2023 at 12:45
  • Yes, either a fuse works or it doesn't (for the most part). That was the reason I asked, because if it works, why replace it? Is, according to the manual, the fuse of the right amperage as it should be? Maybe someone installed a higher amp fuse than it was designed for? Commented May 14, 2023 at 13:42
  • I replaced it because it was melted. (actually the plastic cracked when i tried to pull on it). As I noted - the manual does not provide an amperage...
    – JoSSte
    Commented May 14, 2023 at 14:35
  • 1
    If the fuse holder, both clips and wiring are burned, this may be a loose connection creating intermittent resistance that may cause heating up of the fuse holder and wiring. The electric clutch can draw as little as a few amps to over ten amps. Higher amperage draw places a premium on factory crimped electrical connections. Examine wiring in the fuse area as well as the length to the clutch coil and ground.
    – F Dryer
    Commented May 17, 2023 at 2:03

2 Answers 2

1

I would replace the primary power feed & fuse holder as well as the ground wire. I would do a resistance test on the switch also. If it has any resistance it's time to replace it.

1
  • I replaced the fuse holder this last weekend. no success. My focus is on the switch now too...
    – JoSSte
    Commented May 23, 2023 at 6:43
0

After a thorough search of the wiring diagram and a consultation with a "local" mechanic with experience with this mower I narrowed it down to two possibilities:

  1. The seat switch (which can deteriorate over time)
  2. The reversing switches which, if both are activated, disable the PTO.

I wiggled the reversing contacts and pulled the PTO contact, and the PTO clutch activated.

wiring diagram

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .