I own a 2014 Ford Focus, with a 4-cylinder turbocharged engine. A few years ago, it developed a rather interesting issue. After I put gas in the tank, it gets hard to start, and is hard to keep running for the next few minutes.

It's not the amount of gas in the tank that triggers this, it's the amount I put in while fueling. If I put in half a tank, the symptoms are exactly the same, regardless of if this fills the tank from almost empty to half, from 1/4 to 3/4, or from half to full. If I put in a quarter-tank's worth of gas, the symptoms aren't quite as bad, and if I fill it all the way up, it usually takes at least two tries to get it started and I have to keep a slight bit of pressure on the accelerator for a few minutes to keep it from stalling.

I don't have any idea how to go about diagnosing something like this, so I haven't tried anything beyond testing with different grades and brands of gas (no change). Aside from a slight cooling system leak, there's nothing else wrong with the car.

Anyone got any idea what the problem could be?

  • 2
    Welcome to Motor Vehicle Maintenance & Repair! Apr 12, 2022 at 11:29
  • 3
    Sounds like vapor lock. Is that still a thing? If so, it has more to do with the amount of time than the amount of gas. Apr 12, 2022 at 19:49

6 Answers 6


The next time you plan to buy gas, open the gas cap, do not add gas, leave the gas cap open for the amount of time it normally takes to fill the tank, then replace the gas cap and start the car. Hard to start or not? Then immediately do a normal fillup with gas. Hard to start or not?

This will tell you if it's the act of adding gas or the act of releasing pressure on the fuel system that causes the hard starting. That will get you started on a diagnosis.

  • 2
    Or simply the time it takes to fill up gas. I had a van that was hard to start if you turned it off for a certain number of minutes.
    – AndreKR
    Apr 12, 2022 at 16:30
  • 13
    There is an old story about a car that didn't like a specific flavour of ice cream: the popular flavours were at the front of the store, the others at the back. The additional time to fetch from the back allowed a vapour lock to set in.
    – studog
    Apr 12, 2022 at 21:45
  • 3
    @studog - yep, came to note the similarity to that story. cs.cmu.edu/~wkw/humour/carproblems.txt (and some variations on snopes.com/fact-check/cone-of-silence )
    – Stobor
    Apr 13, 2022 at 6:17

Modern cars all have what is called the evaporative emission control (EVAP) system. This is a system of valves, tubes, and a charcoal canister that is supposed to capture the excess vapors from the fuel tank and then slowly feed them to the engine to be burned. This keeps the raw fuel vapors from being released into the air and causing pollution.

What happens is that sometimes, often due to overfilling the tank, the canister gets saturated with gasoline and then it can dump raw fuel into the engine which can make it hard to start or run rough after starting.

The first step is to determine if the canister needs to be replaced. Remove it and see if it's saturated with fuel. If so, replace it. But also check to see if there is some problem with the rest of the system including the electrically operated valves that control the system as well as the lines to make sure they aren't kinked, blocked, or broken.

  • 1
    Would only partially filling the tank help diagnose this? If the car starts fine after a partial fill, then the canister probably won't get flooded
    – CSM
    Apr 13, 2022 at 7:50

I had these exact symptoms on a turbocharged Subaru, and the problem was the Purge Solenoid Valve was stuck open. In modern EVAP systems, instead of venting fuel vapour to the environment, there is a valve that bleeds it into the engine to be burned. Except if that valve gets stuck open, not only does it produce the exact symptoms you describe as the startup mixture after fuelling is way too rich from all the fresh vapour, but also could have en effect on mileage as the fuel/air mixture could be thrown off. Replacing the valve (*on a Subaru, dead easy, it sits on top of the engine intake) fixed the issue.

In my case there was no CEL code corresponding to the issue.


The other answers deal with the tank venting and pressure, these are pretty much probable causes.

There is one more (analogous to the famous Porsche that didn't like a particular type of ice-cream) : a leaky injectors or fuel pressure regulator.

After you cut the hot engine off, a leak brings some fuel into the inlet air path, until it depletes the residual ramp pressure. The fuel evaporates and fills the air inlet with vapors. If you try to start the engine after a minute or two, it refuses to start because the mixture is overly rich. If you leave the car overnight, the fuel vapors escape to the atmosphere and the engine starts normally.

Things to try:

  • stop the car for the usual few minutes at the gas station. Don't do anything else, just try to start it.
  • fill the tank as usually, then try starting with the accelerator pedal pressed to the floor. Note if the engine starts normally or has the same difficulty starting.

A pedal pressed to the floor when cranking instructs the ECU to skip the starting enrichment and to try to start the engine with a lean mixture instead.

  • Your second bullet point is not a good diagnostic tool. On fuel injected engines, this can have other unwanted consequences having to do with the throttle position sensor (TPS). In some vehicles, having it to WOT when trying to start the engine will reset the TPS to "0" (zero % throttle) when it should be reading WOT (or 100% throttle). Apr 12, 2022 at 17:46
  • @Pᴀᴜʟsᴛᴇʀ2 Are you saying that the TPS reading is calibrated on every start? Tell me the make and model not to buy.
    – fraxinus
    Apr 12, 2022 at 17:58
  • I'm not saying it gets calibrated on every start. I'm saying putting your throttle at WOT on a fuel injected car, then trying to start it, is not good practice. Apr 12, 2022 at 18:07
  • It is not a good practice because it gets you a dead lean mixture that is unlikely to ignite. This is a method of recovery when you wet your spark plugs with fuel (inherited from carburettors, esp. automatic-chocke carburettors). The problem is rare in EFI engines, but pretty much possible.
    – fraxinus
    Apr 12, 2022 at 18:14
  • 1

Could be bad fuel pump or wiring to the fuel pump.

I had a similar problem in 2004 with my 1995 Ford Aspire. I always thought it was bad gas but it would go away after a few minutes, and I only filled it 1/2 way because the tank leaked at the seam. Then after putting 100 lbs of bagged rock salt in my trunk, it stopped working altogether. I was next to a dealership so I pushed it over and they said I needed a new fuel pump and gas tank. They wanted $2000, more than I paid for the thing. After buying a new car, the Aspire fired up perfectly fine, and the dealership then told me it worked intermittently for them. By then I had committed to giving it to a coworkers 15 year old son, who claimed he simply rewired the electrical wires to the pump and it worked fine.

It looks like the Ford Focus has its fuel pump inside the gas tank mounted on the top just like the Ford Aspire. I can only guess why it happened after filling the tank and putting stuff in the trunk, maybe shifting of the weight moved the wiring just enough to not get a clean connection and 100lbs in the trunk broke the connection.


I can't diagnose it with a sentence, but I'd try leaving the gas cap off while you start/run it. Is there any difference that you notice? As others have mentioned, there is a pressure system connected to the fuel tank for pollution mitigation. Changing the pressure in the tank with the missing cap might help your troubleshooting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .