2

I performed a rebuild of my both cylinder heads on a V6 engine, in order to grind leaky valves. I performed a test of each valve pouring isopropyl alcohol in the intake/exhaust chamber and waiting long periods of time to make sure none leaked, going back and redoing the grind until no more leaks. I am very confident I did this right. Because I was doing this along other things in life on a hobby project, it took more than a month and during that time the open cylinder tops were uncovered although the hood of the truck was of course closed. Nevertheless, some rust collected inside the cylinder sleeves.

When I did a compression test, I was getting exactly 0 compression on each cylinder. Then I did a cylinder leakdown test with 100 psi out of an air compressor and I was getting 90% leaks (out of 100 psi coming in, only 10 psi would stay) on every single cylinder. The cylinders were leaking some (15-25% leak) but not nearly as much before the rebuild, which is partly why I did it. For reference, no cylinder should leak more than 20%.

I am confident that

  1. I installed the head gaskets properly and torqued each bolt to spec, and then to yield.
  2. The cams were in correct position on each cylinder when the test was performed, not pressing any of the valves open.
  3. All the three timing chains are installed correctly.
  4. It is not the valves that are leaking (it would not be so consistent if some were)

Is it possible that, while the heads were off for the rebuild, so much moisture penetrated into each piston, as manifested by the minor rust that collected on the sleeves, and that the rings rusted, causing them to leak? Even if that happened on some cylinders/pistons, I find it hard to believe it would happen to the same rate on every single cylinder. What else could explain this consistent kind of cylinder leak across 6 cylinders? I hope that it's not the piston rings that are leaking because that would be off my limits at this point. I was able to hear a hissing noise associated with the leak but was not sure whether it was coming from the crankcase, which would confirm my suspicion.

I asked here before about testing only the piston rings for leak but did not really get a good instruction.

1

0

You must log in to answer this question.

Browse other questions tagged .