I have a 94 Toyota Camry, that used to run well until last week when the negative battery cable snapped from the terminal and caused the vehicle to lose power and ultimately die. I reconnected the cable but the vehicle wouldn't start.

Over the last couple of days I got the starter, battery and alternator tested at Autozone they all tested to be in good working condition. I reconnected everything and still when I turn the key the starter clicks but can't turn over the engine.

It's a no start/ no crank issue, but I tested almost everything needed to make an engine crank but nothing works.

  • I tried jump starting the vehicle
  • I tried jump starting the starter
  • I even tried starting the vehicle in gear

None of these worked.

Is there something I'm missing or anything else that could cause this issue?

  • Put an extra jumper cable between bat negative and the engine ( solid metal part) and try starting then. Also put a jumper cable between bat plus and starter - if it works with either then you have a falty connection or cable - just need to work it through.
    – Solar Mike
    May 12, 2021 at 19:38

2 Answers 2


You must first ascertain if all the battery and starter connections are good. This is copied (and amended) from another question here (not a Duplicate as the Answer there remained unaccepted):

The symptoms may be caused by a bad connection in one or both of the big wires that run from the battery to the engine and chassis.

Loosen the connection at each end of both cables, remove the cables from the battery post or bolt, then clean the connector, the post, the bolt until the connecting surfaces are clean and shiny metal. Then remount the cables.

It's also possible (but less likely) that there's an internal fault in one of the cables or connectors, so that while the connecting surfaces and terminal posts are clean, electrical conductivity is broken somewhere invisible to the eye. If you have a charged battery and clean connections, and there's still no illumination of dash lights or the starter still isn't working, you'll have to use a voltmeter, or continuity tester, or rig a temporary test light to ascertain if one (or more) of the cables is faulty.

  • I don't think this is the issue because I'm getting power to my starter, my lights, the dashboard and radio all work fine. The starter even spins and clicks with the flywheel but its unable to turn over the fly wheel. May 12, 2021 at 17:29
  • 2
    @stephencarvalho That the starter operates and clicks with the flywheel but does not crank the engine over is completely consistent with not enough current getting to the starter - enough to begin to operate it, but not enough to do the work. This indicates a connection or a battery failure. As long as you have not examined and (if necessary) repaired the battery connections, and you haven't tried jumping the car with a known good battery (not one merely judged as OK by an auto store...they are frequently incorrect), your conclusion is no more than a guess. SolarMike (above) agrees. May 12, 2021 at 21:41
  • 1
    There is also a possibility that the engine is seized. Can you turn the engine by hand using a wrench on the crankshaft pulley bolt?
    – Jupiter
    May 13, 2021 at 1:18
  • @Jupiter While a seized motor wouldn't turn, the OP's presentation about the circumstances under which the motor stopped running are much more suggestive of an electrical fault rather than a coming-out-of-nowhere big mechanical issue. I agree it'd be easy to test, provided the OP knows which way the crankshaft turns. May 13, 2021 at 2:27
  • @DavidSupportsMonica. I totally agree with you, but I would make that simple test to rule out that problem with a car this old. Then I could go gun ho on finding the probable electrical problem.
    – Jupiter
    May 13, 2021 at 13:14

After trying everything, I tried rotating the crankshaft using a breaker bar and it wouldn't budge. I ended up selling the car. The person who bought the car later told me that a Rod had come loose from the crankshaft and thus the engine is toast!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .