1

My car, a 2004 Opel Astra, has new windshield wipers. Whenever I go to use them (since it's the start of winter right now) they wipe some water off, but it's never a "clean" wipe (like a .. residue? on the windshield) and it makes a god-awful screeching noise.

It wipes the entire area that I expect it to wipe, but I have extremely sensitive hearing and moderate tinnitus, which makes this scenario almost impossible for me to drive with.

Is it possible that the windshield got damaged since it was standing for a while (due to broken gearbox)? If so, what steps could I take to fix this? I have Googled for windshield polishing, but honestly I have no idea how to interpret the results, or if that's even the issue.

10
  • Welcome to Motor Vehicle Maintenance & Repair! May 9 at 2:50
  • @pᴀᴜʟsᴛᴇʀ2 thank you! I have loads more questions, but I'll start here :p
    – gear4
    May 9 at 3:05
  • What have you tried to do to clean the windscreen? If the windshield is still clear, it is most likely not damaged in any way. It more than likely just needs to be completely cleaned. Using some IPA or acetone might do the job. May 9 at 3:41
  • I will do, thanks. I'm completely clueless on this topic, and my local shops usually gouge me when I ask for help :)
    – gear4
    May 9 at 3:42
  • If you lift the wiper arms, do they move freely under the tension of the spring, or have they become stiff due to corrosion where they pivot up?
    – HandyHowie
    May 9 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.