0

One of week of extremely cold my Honda CRV 2014 battery died and I changed it with new one but the car neither started nor light or click it. I haven’t seen any problem before. Is there any suggestion I could get how I can I fix that issue please.

1
  • We will leave this one open because the OP used an "unregistered" account for the other question. I have already closed it. Feb 22 '21 at 9:59
0

I would check all the terminals and connections - it is possible you disturbed something when you replaced the battery.

The battery terminals need to be clean and tight

2
  • Exactly so. The OP should make sure that both ends of all the big-wire cables are examined: faults may appear anywhere, including the hard-to-get-to connections where the battery cables connect to the car body or engine block, often way down there in the engine compartment. Jul 22 '21 at 15:09
  • Also, I always had a misconception that "terminal grease" needs to go all over the terminal - apparently it only needs to go over the top of the connection. The terminal, and terminal clamps, should be absolutely clean, maybe even lightly sanded, then wiped with alcohol. Though, for full disclosure, I have never seen over-use of terminal grease ruin a connection. Just to be clear, the terminal clamps should have ZERO play - they should not rotate or move up or down. Do not over-tighten if lose though, sometimes batteries are defective in the sense of the terminals being too small.
    – VSO
    Nov 19 '21 at 14:36
0

Your + battery cable has one thick wire and one or more thin wires. Look carefully along the length of the thin wire(s) to find an in-line connector that you may have inadvertently pulled apart. The car will be electrically dead if the connector is disconnected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.