0

I have a 1999 4L60E from a 1999 Suburban that has been rebuilt twice successfully, and then had a TransGo 4L60E-HD2 shift kit installed that ultimately led to where it's at now with it's reverse and 1st only issue. I've been through quite a bit of troubleshooting and am basically at a loss

  • Speedometer is working correctly
  • Both shift solenoids have a resistance of 25 Ohms and click nicely with a 9v battery
  • If my transmission control/PCM is unplugged completely it limps still in 1st gear (which to my understanding is supposed to be impossible, since both solenoids being off should be 3rd)
  • You can kind of feel the transmission try to shift to 2nd barely when it's supposed to, and then stops "trying"
  • Commanding gears with the trans controller doesn't change anything
  • Using the gear selector/tree also doesn't get out of 1st/R
  • Sonnax Corvette servo installed with just enough shims to allow the input shaft to still be hand-rotatable
  • Nothing I've torn down so far has any wear, and there's been no odd noises coming from anywhere while driving
  • TPS shows correctly in my transmission controller software, reading from about .5v to 3.4v

Based on what I can find out by other forums and such, this collection of symptoms seems to be a very uncommon one. It was working 100% before the shift kit install, which only had us replace parts in the valve body, but it was never able to shift out of first since.

I currently have the transmission out with the valve body partially disassembled. What should I be testing?

4
  • Send it to Precision Transmissions - they have some really good videos on youtube. – Solar Mike Nov 11 '20 at 5:40
  • @SolarMike Lol I'd rather fix it, this is a project/not my daily driver and my goal is to learn how to fix issues like this – Brian Leishman Nov 11 '20 at 14:04
  • Check to see if they have done one for your tranny - may be they say the one thing that might help. Just think their comments as they take it apart are so good "oh look been slammin' it into drive - classic evidence" etc :) – Solar Mike Nov 11 '20 at 14:07
  • They did not , but we solved it watching my personal favorite, Transmission Bench guy, answer posted! – Brian Leishman Dec 7 '20 at 14:17
0

Found out what was wrong! It was my stupidity, unfortunately, but that's the goal I suppose, is to make mistakes and learn.

So the problem was, that while installing we broke off the top of the 3-2 downshift solenoid, and ended up needing to replace it. Somewhere in the middle of that, we left out the 3-2 control valve and spring completely. Luckily when tearing it down we noticed that as the issue, found the parts, reinstalled, and everything worked wonderfully!

enter image description here

The rest of the shift kit instructions were followed to the letter, including flipping all the valve body pistons upside and whatnot, and it's working great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.