1

I need help. My 2009 Chevy Malibu was working fine, the next day I was going to turn it on, it didn't. There was no crank, no clicking, no lights inside turning on. Nothing, just dead. I have replaced the battery, the alternator and have checked the fuse box and relays and those are working fine. What can it be? Any input is greatly appreciated!!!

6
  • Use a multimeter to check if you have power to the fuse box. – HandyHowie Nov 3 '20 at 18:10
  • "I have replaced the battery, the alternator and have checked the fuse box and relays and those are working fine" It is still completely unresponsive AFTER you did all that? – Alaska Man Nov 3 '20 at 18:29
  • @AlaskaMan, yes, after all that it is still unresponsive. – Aleyda Nov 3 '20 at 22:03
  • Have you checked all the relays? I believe your vehicle has three fuse boxes - one in the engine, one in the passenger floor well, and one in the trunk. The ignition relay located in your engine compartment fuse box might be bad. A good trick is to just swap it with another relay in the box, and see if it magically starts working. (Just making sure you've checked that one specifically.) – the_storyteller Nov 3 '20 at 22:46
  • Have you checked the electrical integrity of the big battery cables and the condition of the cables' connectors? A cable might be broken internally, and given the car's age, might well have degraded connectors or bad cable-to-connector joints. – DavidSupportsMonica Nov 4 '20 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.