1

Recently I started noticing a weird problem with my car (Maruti Alto LXI 2009, Manual petrol with carburetor) that when I press the clutch pedal and the car is in gear it hesitates (it cranks but not enough for starting) to start. Tried pressing the brakes and putting the car in neutral the car starts normally. Got it checked by authorised service center and they suggested to replace both the clutch(5 years old and ran around 25000kms) and battery(only 3years old). Is this normal? If any other information is required please feel free to ask.

  • What do you mean by "hesitates to start?" When in gear with the clutch pedal pressed down, does the motor start or not start? Does it crank? – DavidSupportsMonica Sep 2 '20 at 3:04
  • @DavidSupportsMonica it cranks but not enough for starting – Nilabja Sep 2 '20 at 3:52
  • That's an answer @DavidSupportsMonica – GdD Sep 2 '20 at 7:49
  • i will get the clutch checked out, the clutch cable seems to be fine – Nilabja Sep 2 '20 at 12:00
  • @GdD Thanks, you're right. I'll post it as such. – DavidSupportsMonica Sep 2 '20 at 14:39
2

This suggests that when the clutch pedal is pressed, the clutch is not fully disengaging. Check the linkage (if mechanical), or the hydraulics (if hydraulic).

If these systems are operating correctly, then you'll probably have to disassemble things (I don't know how the Alto is designed) and examine the internal clutch pieces and bearings for faults.

  • got the clutch plate and pressure plates replaced and that seems to have solved the issue – Nilabja Sep 3 '20 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.