0

I have two ODB devices. One is ELM327 Wifi OBD2 and the other one is OBDLink LX Bluetooth.

My problem is that none of the OBDs connect to Toyota cars.

More specifically:

I have tested the two OBD devices on 4 cars: Mazda, Honda, Toyota(Auris), Toyota(Yaris)

  • On Honda and Mazda: The devices are connected and the measurements appear on the dashboard as they should be.
  • On the two Toyota cars: The OBD devices are connected but the measurements do not appear on the dashboard. Both cars were made on years near 2010 (don't remember exactly).

I've tried both OBD devices with 2-3 different apps (including Torque Pro).

Here's a screenshot from one of them that tries to connect to the ECU (After 10-15 minutes of waiting I closed the application)

enter image description here

It seems like Toyota cars have some sort of setting that restricts the connection between OBD and ECU.

Do you have any idea what might be causing the problem and how I could fix this?

  • Welcome to Motor Vehicle Maintenance & Repair! – Pᴀᴜʟsᴛᴇʀ2 Mar 23 at 23:28
  • Your title says an issue with a Honda connection but the body says Honda works... Can you clarify. – Solar Mike Mar 24 at 6:24
  • I'm really sorry. Corrected. – John Mar 24 at 22:39
0

It looks like you are using Car Scanner app. Good choice.

connection profile Which Toyota connection profile are you using?

Car Scanner —> Settings —> Custom Sensors —> Choose Connection Profile —> Car Brand —> Toyota

| improve this answer | |
  • Yes Im using the first one. – John Mar 24 at 22:52
  • Looks like there are five profiles perhaps appropriate for 2010 Toyotas. Did you try each? Results? – zipzit Mar 24 at 22:58
  • No I've tried only the first and the second. But I've also tried the OBDLink by using the OBDLink app and it also doesn't work. I'm almost sure it doesn't have to do with the application because none of the OBD works with any application on both Toyota cars. However, they do work on the other two cars I've tried.. It's really strange. – John Mar 24 at 23:03
  • Suggestions: 1) try both android and apple versions of the app, see if they differ. 2) Try to post this question on a Toyota specific discussion forum, possible answers there. 3) Finally send a message to app developer, ask for their input... – zipzit Mar 25 at 1:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.