1

2003 Kia Spectra, here's the backstory : I recently changed the spark plugs and soon after doing so I tried to turn the car on and it only cranked. The owner before me probably try to work on the engine and now there's no spark plug harnesses at the end of The wire it's only two little bare metal clips that plug into the prongs, so I thought maybe there was no spark. I check for spark and there was spark but for some reason the car doesn't start. still not turning on, l I flip the polarity on the metal wires thinking that might have been it but after doing that it blew my ignition fuse lol Then I realized I couldn't hear the fuel pump turning on so I bought some starter fluid and it started up so I guess that was my fuel pump. I bought a new one I put it in and it still didn't turn on, only cranking. I ended up jumping the the terminals at the relay and the the fuel pump starts right up but the problem is it won't turn off now so in order to turn off the fuel pump I have to take out that paperclip and put it back in every time we start the car. I checked and cleaned my ground connections and checked for blown fuses and loose connections and broken wires. I haven't traced the wiring from the fuse box to the fuel pump yet because I get headaches inspecting every single eclectical connection. Can anyone point me in the right direction to figure out why brand new relays don't turn the fuel pump on?

1

If jumping the terminals at the relay made the pump work, then there is no point in checking the wiring from the fuse box to the pump, since you have just proved that it is OK.

Things to try -

Swapping the relay with an identical one from your fusebox - This will test the pump relay in another circuit and also try a known good one in the pump relay circuit.

Remove the relay then connect a 12v bulb between connection 85 and 86 in the socket where the relay was removed. If the bulb lights when you turn the ignition on then the signal to operate the relay is working.

Report back with the results of these tests.

| improve this answer | |
  • Haha of course the wiring is good if I jumped the terminals and the pump turns on, duh🙄 sometimes I can be an airhead it seems. Before I jumped the terminals, I DID test it with known working relays. The horn relay is exactly the same size, had my gf beep the horn to confirm that it works. Swapped it with the pump relay and had her turn the key - nothing. Only cranking. Told her to press the horn and it beeped, telling me that the relay was still in working condition. – Nathaniel Davidson Mar 16 at 11:10
  • I will try the light bulb test tomorrow, but I did test the terminal with my multimeter... The hot terminal - 30 I believe - is indeed hot with 12v with the key off. Testing the other power terminal, which supposedly has power only when key is switched to on, registered a 0 with key off (as expected) but also 0 when key switched on. I neglected to test the terminals you speak of though but I will do so tomorrow and post my results here – Nathaniel Davidson Mar 16 at 11:11
  • Have you checked if there are any other pieces of equipment that are no longer working with the ignition switched on, for example the window wipers? – HandyHowie Mar 16 at 11:37
  • Everything else is working. I've checked pretty much everything that is in that fuse box... Something strange though... After taking out the paperclip from the terminals I hear a loud buzzing coming from the IAC module. It's right next to the MAF so initially I thought that's what was making noise... But no, after jumping the terminals again to recreate the buzzing I narrowed it down to the IAC... Wonder what that's about? – Nathaniel Davidson Mar 16 at 11:52
  • @NathanielDavidson - The MAF shouldn't make any noise (none you could hear, anyway) ... the IAC is electro-mechanical, so very easily could be making noise. I wouldn't think too much about it at this point, because it shouldn't be causing the fuel pump to not run. If there does seem to be a separate issue with it, please followup with a separate question. If you include it here, it will get lost and this thread will become very messy. – Pᴀᴜʟsᴛᴇʀ2 Mar 16 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.