1

Car in question is a 2010 Mazda 3 2.5L. 193,000kms.

My car's temperature starts to rise when idling or driving at low RPM. Before this problem started, the coolant temperature always stayed at 88C. Now when the car is idling or in stop and go traffic the temperature keeps rising unless I turn on the heater full blast. When driving on the highway, the temperature stays around 93C(5 degrees above normal), but does not rise above that.

However, on the highway on if I stay on a lower gear and keep the RPMs above 4,000, the temperature drops and stays at 88C as normal.

Also, the radiator fan does not seem to turn on when the temperature is rising. However, it does turn on when I turn the AC on.

What has been done already:

  • Changed the thermostat.
  • Drain the coolant and filled it with new coolant.
  • Bleed the system of any air.

I'm trying to figure out and fix the cooling fan issue next. Do I also need to change the water pump because the overheating does not occur at high RPM?

7

This sounds like a problem with the radiator fan control system to me, the radiator fan should turn on automatically when the temperature reaches a certain temperature, and switch off when below. We know it works because it comes on when you turn on the AC, so that means the control module is probably okay, the issue is most likely the temperature switch has failed. I wouldn't mess with the water pump, I don't see how that would be the problem in this case, try the temperature sensor.

| improve this answer | |
  • Thanks for the answer. I will fix the fan issue first and check the temperatures again. – rana Mar 9 at 15:11
3

If your cooling fan is running the water pump might be failing,it is often the impellar coming loose from the axle in the waterpump so you will need a new waterpump.

If your cooling fan does not start the car will overheat while standing still idling,but when you are driving the airflow thru the radiator will keep the engine cooled but if you drive uphill or uses more power the cooling can not cope.

You will have to take a look at the fan controll circuit,look for a blown fuse-bad connection-broken wire-fan controll thermostat(most likely fault)or a broken wire the fan motor itself might be broken if so the fuse is likely blown.

| improve this answer | |
  • I agree. The speed of the water pump is controlled by engine RPM. If the water pump is failing, and is (for example) pumping 30% less water at all RPMs, it may not be pumping enough water to keep the engine cool at low RPMs. I think 193km (120mi) is a reasonable point for a water pump to fail at. – Sam Mar 8 at 20:32
  • 3
    @Sam If my water pump would fail every 193km, I'd have to replace it at least twice a week. – Mast Mar 9 at 6:56
  • 1
    @Mast obviously a typo 193k km.the op have updated the question so the waterpump is most likely okay,so the fault is in the fan controll cicuit.this does not mean the waterpump is good. for another 10k km – trond hansen Mar 9 at 7:04
  • @Mast hahaha good catch – Sam Mar 13 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.