3

The headlights on my Mazda B2900 diesel pickup won't turn on.

The failure happened yesterday and suddenly, with no previous problems like flickering or signs of false contact in the switch.

They worked fine on the first drive of the day, on second drive both lights won't work, neither high or low beam, however I can flash the high beam by pulling the lever. Both ligths flash.

Ive had checked both fuses related to headlights. There is one under the dash, rated 20A, and another under the hood near the battery, rated 30A. They both are conductive.

I've been unable to find a relay to check. So that's question one: Where is the relay located, if any? What else should I check?

I don't think the switch is at fault, as both beams failed at once but the flasher still works.

I attach a picture of the engine bay and fuse box in engine bay. The headlights fuse is the broken one. It is still conductive, I accidentally broke the plactic cap while trying to remove it.

The car is a Mazda Pickup, model B2900, year 2004, diesel naturally aspirated, made in Philippines.

enter image description here enter image description here

Follow-up Nr. 1: I wrote this question right after fiddling with the car looking for the relay and turning the switch on and off several times, lights where still inoperative. At the end of day, when leaving workplace, the lights did turn on at first attempt and continued to operate normally on several tests and even today at morning, the lights came on every time I actuated the switch. So, it is an intermittent(?) Kind of failure. I'm planning on disassembly of the steering column cover to check for loose or dirty connections.

Folow up nr 2 The failure happened again on Jan 2nd,2021, almost a year after I sprayed the suitch with electrical motor contact cleaner. I sprayed again today, this time used computer contact cleaner an quickly the lights where operative again.

Unfortunately there seems to be no way to disassemble the switch t clean it properly.

My guess is that carbon buildup in the contacts is preventing conductivity.

2
  • Welcome to Motor Vehicle Maintenance & Repair! – Pᴀᴜʟsᴛᴇʀ2 Feb 17 '20 at 21:27
  • There is no relay on that model, so most likely the switch, as answered below. – Moab Feb 17 '20 at 23:26
2

The problem is most likely the headlight switch itself. The part which does the "flash" is a different part of the switch than what turns the lights on.

enter image description here

2
  • @narkeleptk - Thanks for the add! – Pᴀᴜʟsᴛᴇʀ2 Feb 17 '20 at 21:50
  • 2
    I'd have to agree with Paulster on the multifunction switch. I included a schematic in his post from a 98-05'ish Ranger. which is pretty much the same thing. There's not much else it could be if the flash to pass is working. – narkeleptk Feb 17 '20 at 21:57
0

Solved

The described issue continued to happen intermittently and seemingly at random.

I disassembled the steering column cowling and found that the switch and lever module could be just pulled off.

I used a bit of "contact cleaner". A product marked to use for electrical motor cleaning. I sprayed the outer contacts and tried to make it go inside the module and then let it evaporate for an hour before reinstalling.

It has never failed ever since.

enter image description here

enter image description here

Update: a few days ago (Jan 2nd) the failure happened again, about a year after the previous occurrence. Today I removed it again and sprayed this time with context cleaner for computer parts. It quickly made contact again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.