0

So I've been back and forth with why my bike keeps fouling a plug in cylinder 4. Intermittent firing and real poor performance. Motor would shut down while in 4th gear. Sketchy clutch at start, super jumpy. Black inside exhaust pipe. Started at the spark plugs then went to clean each of the fuel injectors and then tested ignition coils all reading with proper ohms. Then I pulled this out from under my seat. I have one question. Can my bike start up and act like it's been with an ECU that looks like this? Please notice the photo i've uploaded. If so, I don't know what else it could be. Thanks for any input. It's been a journey and I'd love to just get back to riding...So we're clear, I bought this bike from someone without going over it.. "Rookie Move" enter image description here

1

. Can my bike start up and act like it's been with an ECU that looks like this? Yes. Its very possible and likely the ecu, the wiring going into the harness or the harness molding between the terminals that is bad from the looks of it and the symptoms you mention.

It looks like the heat that damaged the case (maybe more) was from outside, so I would get that fixed as well.

  • New ECU and harness.. Installing a new harness is gonna be a nightmare I bet.. – Rendering1 Jan 19 at 4:42
  • Its not too bad if you do it the lazy way. Some connectors with heat shrink already on them. like: tinyurl.com/thjdggw . Never tried the ones with grease already in them but they may be the way to go. Like: tinyurl.com/tg2u6rx . I would just check the wiring first. The ecu itself is heavily coated in potting material so it may be ok. – narkeleptk Jan 19 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.