2

When driving for a bit at 70 mph. Headlights, dash lights, and radio start to cut in and out. Alternator has been replaced. When idle I've tested the battery and alternator stationary, everything turned on, and over 2000 rpms. All pass.

I also have this other issue where everytime I get gas my car wont start, it takes a minute to crank.

Could the fuel pump drawing too much power cause this issue?

  • 1
    Welcome to Motor Vehicle Maintenance & Repair! How did you test the battery? I've seen a battery fail provide the power the alternator needs to keep up its field, and therefore will not generate enough power be charged (this is with a lot of accessories on), but then still show over 12vdc when parked. You need to have the battery load tested. – Pᴀᴜʟsᴛᴇʀ2 Jan 13 at 22:19
  • Also check that the grounds are in good condition; if current cannot get to ground, it will cause all kinds of weird drivability issues. – PeteCon Jan 14 at 4:24
  • When you say "Headlights, dash lights, and radio start to cut in and out", do you meant that they completely turn off and then come back on? If not, can you describe what happens in more detail? – HandyHowie Jan 14 at 7:52
0

This sounds to me like you have a fuel problem.

The first thing to do is to look at the fuel filter to see if this is clogged up,this is typical when your car looses power when driving.

The second thing is to see if the fuel pump give the right amount of fuel at the right pressure,to diagnose this you need to take of the fuel hose(put the end of the hose in a bottle to collect the fuel)turn on the ignition to see if the pump is running and producing a good fuel flow(in most cars the pump starts when you turn on the ignition if not you need to run the starter for the pump to start).

The last thing is to take a look at the electrical system,bad battery-loose connection-charging system,focus on the battery connections and the grounding as this is often the cause for problems.

|improve this answer|||||
  • I read the question as though the OP is loosing electrical power rather than engine power. What makes you think there is fuel problem? – HandyHowie Jan 14 at 9:50
  • the op have a new alternator and the electrical system have been tested and found to function,and there is the cranking after filling gas it sounds like it takes too long to build fuel pressure.my understanding of the problem might be wrong but i find it strange to loose electrical power when everything is okay up to 70mph. – trond hansen Jan 14 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.