1

At first i thought it was random, then i realised that there is clearly a pattern:

  1. I start the car then i check and both the wiper and the window works as expected.
  2. 20-30-40 minutes down the road i have checked again and neither of them works.
  3. Restart, wait 5 minutes or so, and everything is back to normal.

Checked/replaced the fuses they are fine, also reconnected the switches for the powered windows. No effect unfortunately.

The car has the original battery, but it seems to be working great starts the engine with no problem even in the winter. So it seems pointless to replace.

Do someone has any similar experiences with a vehicle?


Car info

2007 Opel Vivaro

2.0 CDTI (Diesel)

original battery, but it works great

no previous electrical issues whatsoever

0

In most vehicles, the body control module (BCM) controls these things. Your switches just tell the BCM when to activate what. I'm not sure if that's what's wrong with your Opel, but it sounds like it might be. Also, have your battery checked professionally. It may have enough power to start the engine, but not enough to run the electronics correctly. A battery normally is only good for about 5 years. If yours is the original battery from 2007, you've gotten some great life out of it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.