0

I have a 2013 Hyundai Accent with 250K miles. In the past year the MPG dropped from 38 to 35. I see that the STFT at idle is about 8-9 and at highway speed stays around 0. This indicates a vacuum leak. I can't find one but while looking for one I pulled my PCV hose off and noticed the STFT went to and stayed around zero. This is the opposite that I would expect. Is this because the ECM noticed the massive vacuum leak and stopped trying to compensate? I know the mileage isn't bad but if there's a way to get more I'll be happy to fix it.

Thanks

1
  • Check to see if the computer stopped trying to compensate by checking, with OBD scanner, the status of "open/closed loop operation". Jan 8 '20 at 17:52
0

ok, LTFT of 14 is a concern it is a sign of a vacuum leak, low fuel pressure or clogged fuel injector. Check for tears in the air intake duct after the MAF sensor. Run a fuel pressure test. If you have to, get it to a shop for a smoke test

1
  • The scanner shows consistent fuel pressure at all speeds. I think it's 850 ish (or 580 but I think it's in specs). If it was fuel pressure or injector wouldn't the STFT stay high at highway speeds? I'll look for issues in the air intake duct. Any other thoughts are appreciated. The car runs excellent but I like to see numbers where they should be.
    – soulTower
    Dec 9 '19 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.