2

My car (Fiat Grande Punto MY2008) has been having an occassional battery light and failure of the power steering. Perhaps once in every 10-15 startups, and is resolved by restarting the car.

The car starts fine, but I am concerned the alternator isn't putting out enough power. So I have taken some readings, which seem a little on the low side to me but not bad enough to strongly indicate the alternator is faulty.

I've taken battery voltage readings, which are as follows:

  • with engine off: 12.4v
  • with engine on (idling)
    • no electricals on: 14.1v
    • some electricals on (fan at max speed/aircon/lights): 13.8v
    • whilst turned steering wheel with above electricals on: fluctuates, but stays above 13v
    • all electricals on (above + rear windscreen heater): fluctuates, drops below 13v

I ceased testing with the rear windscreen heater turned on, as the voltage on the multimeter kept dropping and I was concerned it would drop below 12.4v

Applying some revs to the engine didn't make a noticable difference to the voltage. My understading is that the alternator should output almost 100% power at idle speed anyway. The battery is new.

3

The voltage readings sound fairly normal to me. Also, since you don't get fluctuating voltages depending on RPM, I would suspect the voltage regulator is also good.

I would check elsewhere. Electrical short maybe, or failing electric steering box, or ECU?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.