1

I had new front suspension arms fitted on my 06 Polo today. Now there’s clunking on one side when I go over dips in the road or when braking. I’m thinking maybe the brake is loose or something?

Cheers

  • 1
    Take it back to whoever did the repairs, they left something loose. – Moab Sep 17 '19 at 22:28
  • Had the same on a Landrover, loud clunks turned out to be a loose track rod? as said by @moab take it back to the repairer – Dan K Sep 18 '19 at 7:50
  • Going to have to. Problem is I’m on the other side of the country at the moment and have to drive back 😖 – Luke Sep 18 '19 at 9:26
0

More information on your car would be helpful. Such as mileage.

Here are the places which are a high probability for the clunk you describe:

  • strut bearing/bushing area looseness and wear
  • sway bar bushing (I don't know if the Polo has a sway bar)
  • bushings on control arm
  • linkages, such as sway bar linkages

The noise is not likely a loose brake caliper, but that should be easy enough to inspect with the wheel off. It's not a reliable indicator, but the clunk when braking kind of tilts the probability to the control arm bushings.

| improve this answer | |
  • Hi, mileage is 136,000. There’s was no noise prior to the arms being replaced. Both were minors on my last mot in June. Don’t know about sway bars, but there’s is an ‘anti roll bar linkage’ which appears to be a bar that attaches at one end to the shock absorber (I only know this because I can see where a new one was fitted last year. Thank you – Luke Sep 17 '19 at 18:47
  • Sway and roll bar are the same. Given mileage, I would suspect the top of the struts. – mongo Sep 17 '19 at 18:51
  • I’m with Mongo on this one. Top of strut is just a bit loose. Half a turn loose on top nut generates loud impact noise. Easy fix. Three minutes max. – zipzit Sep 18 '19 at 3:28
  • Thank you. Having watched a fitting video last night that seems to be the only possibility - was thinking maybe they’ve not put any pressure underneath when tightening the nut? – Luke Sep 18 '19 at 6:08
  • Having jacked it up and checked the nuts they seem okay. Leaves the bush as the only culprit, would have thought they’d have checked it when they fitted the arm, so i’ll have to take it back in – Luke Sep 18 '19 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.