1

I have a 2014 Hyundai Elantra, that i have owned for a little over a year now. It has been very well maintained in the time that i have had it. The other day after i finished pumping my gas, i got back in to turn my car on and it made a very loud pop noise. After this my car wouldnt turn on. I had multiple people look at the battery and tell me that the battery had exploded and needed to be replaced. So i replaced it and my car came back on. I tried to drive it and it keeps shutting off at random times. Currently, it will drive but as soon as it is put into reverse it just shuts off. The power steering also seems to have gone out so i havent driven it in a few days. Any ideas whats going on?

  • is it an auto or manual transmission? – HandyHowie Aug 4 at 9:47
0

A battery produces gas when charging, this gas can explode given a source of ignition.

One loose connection can mean one spark and bang, one damaged battery. Actually having this happen with the hood shut is quite lucky... have seen a battery explode and cover several cars with acid...

The car may need to re-learn some settings as a battery disconnection is often used to reset everything. Start it, use it and see what happens.

You should get the codes read, as there might well be several unrelated issues to deal with. Until you have more info, it is difficult to say.

One possibility is that the battery acid from your exploding battery damaged a sensor or two or some wiring or connectors.

  • The OP says that the car was getting used but keeps randomly turning off. – HandyHowie Aug 4 at 9:23
  • @HandyHowie OP also says « i havent driven it in a few days » ... – Solar Mike Aug 4 at 9:28
  • You think the random turning off will go away? – HandyHowie Aug 4 at 9:30
  • @HandyHowie I have had the engine warning light come on and then clear itself two days or so later. Perhaps reading the codes may clarify the situation. It may be there are several unrelated faults happening at the same time - usually known as coincidence... – Solar Mike Aug 4 at 9:33
0

My guess would be that the original fault that caused a spark that ignited your battery is still there. Selecting reverse may be making the engine and transmission move so that it is pulling on a wire connected to the battery which is then disconnecting and stalling the engine. It may well be causing a spark.

I would double check all the connections around the battery for loose or suspicious looking connections.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.