1

my brother was driving his 05 murano at a pretty high speed, the car just slows down on it’s own cuz it won’t accelerate and when tried to turn it back on , it would click one time but won’t turn over? Any ideas on what it may be , I’m hoping it’s not a blown engine but can I get a professional opinion lol

  • 2
    Welcome to Motor Vehicle Maintenance & Repair! Have you checked to see what the voltage is at the battery? Are there any dash lights (ie: check engine light)? If so, what's the codes? My hunch is, the alternator has gone out, then the system drained the battery while he was driving. in this scenario, you could pull the battery out and charge it (or charge it in the car) for several hours, then see if you can start the vehicle. If you are able to do that, then you can check to see if the alternator is working while the car is running. – Pᴀᴜʟsᴛᴇʀ2 Jul 21 at 17:03
  • If you rule out the battery, then I would check out the starter next. – ElectronicsNewbie Jul 21 at 18:09
  • Check The Electric Line !! Check The Fuel System Check The Battery – Rakibul Jul 23 at 7:42
-1

First I suggest, check the connectors. It's possible the battery equips worked out a bit. You can run some diagnostic tests. Those manuals and all surely have those tests procedures and steps. I'm sure mine has it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.