0

2008 Mazda 2 1.3 25000 miles.

The car drives fine with no issues, but when it is warm/hot, it feels like it is going to stall at idle.

The needle drops to 0 revs but it 'catches' itself and doesn't actually stall. The idle doesn't feel particularly rough but it isn't smooth. The revs only drop, they don't increase.

The only other issue is when in neutral, if you pick the revs up to just below 3k, you can feel some engine shake. It is only noticable at a very specific point of revs.

I've chucked some Redex in the tank, have replaced filters, and will soon replace spark plugs. If that doesn't work, I'll buy some MAF cleaner and clean that. Perhaps replace the fuel filter.

Does anyone have any suggestions, in case I'm on the wrong track, or the above doesn't work?

  • I can’t hear anything. I’m not 100% sure on the exact sound I’m looking for but I can’t hear anything out of the ordinary. Tubes and pipes all look good with no perishing etc. – sillysandwich Jul 14 at 17:55
  • Do you have a check engine light? Whats happening sounds a lot like either an intake or exhaust sensor acting weird and choking out the engine, I had a similar issue and was corrected by taking some MAF cleaner to these sensors. – user4321 Jul 17 at 12:48
  • No check engine light but I have MAF cleaner on order.. – sillysandwich Jul 18 at 13:03
  • Are you pulling an codes? If not, I'd check your Throttle Position Sensor (TPS), it soudns like it may be starting to fail. – Henry Jul 18 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.