0

The problem with my bike is that it performs totally fine if I ride it for few km's, say 10-20 max...... But as I ride it for 30 km or more..... It do missing at higher RPM... Say above 5000-6000 RPM. If I give it a rest of a half n hour or an hour.... Then it again works fine for few km but after some time the same problem occurs.... And there is constant vibration at the Handel and at the foot peg at higher RPM... Even if I start it fresh or riding constantly..... Even hero engineers are not able to resolve this problem..... Please help of anybody can....

  • Could it be overheating? – mike65535 Jun 20 '19 at 18:16
  • But how can a bike get overheated in just 30 km..... And can cause such a big problem....and yes.... It overheats too early..... There is a smell after riding it long.... Bt a bike can't get overheated just after 30-40 km na... – Pulkit Sharma Jun 20 '19 at 18:38
  • Just a few minutes in traffic an air-cooled bike can start to run rough. What is the air temperature? – mike65535 Jun 20 '19 at 19:01
  • Brother I live in a place with good temperature..... And with no traffic jams..... – Pulkit Sharma Jun 20 '19 at 19:32
  • I don't know enough about your bike, but if the fuel tank doesn't vent properly, it can cause an issue over time. Try opening the fuel tank when it starts to give trouble. – mike65535 Jun 20 '19 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.