0

I've had my car battery charger for about six months and, just recently, it won't power on. When I connect it to the battery and the mains, the orange light comes on but there is no low humming noise that means its charging. Usually when it was working, I connect it to the battery and the mains, the light orange light comes on and the unit hums because its powered on. Now the orange light comes on and stays on but there is no power sound. Can anyone help?

0

most probably, your charger has a blown fuse. replace the fuse with a known good one. use multimeter and safely check for the voltage across output, i.e. +ve and -ve connectors of your charger.

  • Thanks for that. I thought it could be the fuse, but the orange light does come on when I connect the charger to the battery and the mains. But I can't hear anything that says the battery charger is powered. If the fuse has blown, would the orange light still come on when the charger is connected to the battery and the mains? – Patrick young Jun 17 at 8:34
  • please send the pics. – user30612 Jun 17 at 9:44
  • please upload video or gif !! – user30612 Jun 18 at 8:29
  • I'm not sure how useful an image or video will be as it will only show the battery charger connected to the battery and mains with the orange light on. I really need to know whether the orange light will come on even if the fuse needs to be replaced? – Patrick young Jun 19 at 7:42
  • check the output voltage. – user30612 Jun 19 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.