4

I apologize in advance for the long question. I want to make sure I'm as detailed as possible.

Today I discovered my Toyota 2009 Venza completely dead (kids left the rear passenger lights on... I haven't driven the car for 4 days after) unable to unlock the door with my keyless entry, used the key to unlock the door.

I had to put the car in (N)eutral to roll down my driveway in order to position the jumper cables to reach. My brakes were not engaging so I had to use my emergency brakes to slowly bring the car down.

I left the cables hooked up to the running car for about 5 minutes until I was able to start the Venza. I allowed my car to continue to run for about 10mins more before driving around the block. When I shift to (R)everse the car moved just fine... Brakes works as well. When I shift to (D)rive, the car moves, but unable to accelerate. Speedometer stays at 0 when shifting to R, D, And S (see screen shot)

I pulled over, parked my car, kept it running... Noticed the car made a few beeping sounds ... I looked at the dash, discovered the check engine light AND Hill assistant appear (see screen shot)

I parked the car, checked all the fuses ... All is good.

I checked the user manual, YouTube, Google, and this forum looking for answers. Nothing worked. See below for my efforts.

Idle reset/relearn throttle by turning off and on the car 2x, start the engine, put on the ebrake, shift down to D for 5mins. - attempt to accelerate, FAILED

Disabled TRAC and VSC by holding down the traction button (both icons appeared on the dash as OFF, shift down to D - attempt to accelerate, FAILED

Checked all fuses and made sure all fuses are in position, good and nothing blown. Turned car back on... shift down to D - attempt to accelerate, FAILED

Able to get the car back on the driveway, duplicate the Hill assistant icon on the dash... Turned car back on... shift down to D - attempt to accelerate, FAILED

Disconnect battery cables, cleaned post, reconnect the battery to make sure the post have a good contact... Turned car back on... shift down to D - attempt to accelerate, FAILED

HELP PLEASE!

Thank you, Christine. enter image description hereenter image description hereenter image description hereenter image description here

  • Perhaps a stupid question, but you did release the parking brake before you tried to drive off? – GdD May 24 at 8:13
  • @GdD note the comment above that the car moves fine in reverse. It sounds like the parking brake is not the issue. – Bob Cross May 24 at 11:13
  • 1
    It's not uncommon for cars to roll better in reverse than forward with the parking brake on due to gear ratios @BobCross. – GdD May 24 at 11:21
  • @GdD based on the description above, that isn’t what’s happening. I think the answer below suggesting limp home mode is likely on track. – Bob Cross May 24 at 13:49
  • 1
    Christine, please don’t feel that you need to apologize for a detailed well-written question! – Bob Cross May 24 at 13:51
2

The failure to accelerate sounds very much to me as though the car has gone into "limp home" mode.

This usually happens when the Engine Control Unit (ECU) detects a problem (or thinks it's detected a problem) - by limiting the acceleration you can limit the potential for damage or accidents.

Toyota Venzas do have form for a flattened battery + jump start leading to spurious errors being reported by the ECU, although I believe the "usual" symptoms are a "Check Engine" light and a message on the display saying "Check VSC" which doesn't match with what you're seeing.

I'm not ready to rule out the idea completely though. The multiple errors and unsual beeps still mean I'm leaning this way. After all things that go quack are usually ducks even if they aren't the usual color.

First step is probably to hook up an OBD-II code reader and see what error codes are reported. Make a note of any codes and try resetting the fault codes.

If the problems persist scan for codes again and see which codes are now being reported (any that disappeared were spurious and can be pretty much ignored)

If you don't have access to a code reader and can't get it anywhere where they can do it for you then to clear any spurious error conditions the first step would be to completely disconnect the battery and give it a full charge on a decent battery charger (overnight is advised). Then re-install the battery and see what symptoms (if any) persist.

The zeroed speedometer does sound as though there may be an issue with the ECU reading the wheel speed (there is a sensor on the wheel hub at the front that tells it how fast it's turning and this provides the info for the speedometer), now this could be a spurious one as described above or it could be that the sensor has been damaged during the jump start procedure - it's not hugely likely, and I hope it isn't as they aren't cheap! Another possibility (luckily even less likely as it's even more expensive) is that there is damage to the ECU itself from the jump.

I think to go any further then this I'd need to know what the outcome of these steps were - especially which error codes persist past an attempt to clear them.

Response to Update(s) from OP

P2118 on these indicates a problem with the Electronic Throttle Control System (ECTS to it's friends) and this would fit with the symptoms - when this code is present the car turns the electronic throttle actuator off, and without that you can't open the throttle and you'll only get idle, hence no acceleration.

No throttle response on D, R, and S. I rechecked the ETC fuse as well as all the fuses again, nothing blown

I see you've already checked the usual suspect in these scenarios (the fuse for the ECTS) so there's got to be something else wrong.

The first time I jumped the car was with a 01 civic. Before I was able to turn on the venza, the civic died out too... Seemed like the venza totally consumed the civic power.

Unless the Civic's battery or alternator was on it's last legs I'm surprised that it would die this quickly.. I must admit I'm scratching my head a bit on this one. Some kind of dodgy ground or short with power supply circuit to the ECTS might explain these symptoms especially when you add in the low voltage report from the previous battery check. Is there any indication that it might be draining quickly with the new battery?

PS: No need to apologize for writing a long and detailed question, usually the reverse is the problem! The more info we have the better!

  • Response pt1 I purchased the OBD II reader/scanner Thursday night. Description reads; P2118 OBD-II Trouble Code: Throttle Actuator Control Motor Current Range/Performance. I tried to clear the code several times before replacing the battery. FAILED. Yesterday morning I thought the car wouldn't start the first attempt, felt like the battery died out again. Tried once more, success... Car started. Checked for codes again, same. Tried to clear the code, failed – CHRISTINE May 25 at 11:41
  • Response pt 2 I went to AutoZone to perform the battery test, said low voltage. I figured since the battery is 4yo, might as well change it again... Suggest to purchase their battery @ cost $170+ tax... Eh, I went to Costco got the same battery for $96 out the door! Replaced the battery, BIG FAIL, problem still exist. I checked the fuses under the hood again, nothing blown. Perform the throttle relearn process, failed. Checked for codes again, same. Clear codes, failed. – CHRISTINE May 25 at 11:43
  • Response pt3 I forgot to mention The first time I jumped the car was with a 01 civic. Before I was able to turn on the venza, the civic died out too... Seemed like the venza totally consumed the civic power. Tried to start up the civic again, the battery was dead as well... SO HERE I AM WITH TWO DEAD CARS ON THE DRIVEWAY (FML)... would this have triggered something the venza to "quack" out? – CHRISTINE May 25 at 11:44
0

1.)Take a battery voltage reading with car off what is the DC voltage of the battery? It might be too low for ECM .

Put into learn mode after battery reconnected. Turn key to on for a sec, turn off. Then turn on and start let it run in neutral for 5 minutes. Im not sure if applicable to Toyota - while running turn wheel lock to lock both sides to initiate sensors. If you can drive it for awhile so it can establish how you drive (granny style or race car driver).

  • Battery tested low. Replaced battery, problem still exist. – CHRISTINE May 25 at 11:51
  • - - - did not feel safe on the road as I am unable to accelerate. The farthest I got away from home was probably 500ft before turning back around. I was far enough to where the car picked up enough speed to drive on my inclined driveway. If I was posting up at the bottom, D would not have enough power/momentum to go up, if that makes sense 😳😳 – CHRISTINE May 25 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.