7

I ran out of wiper fluid a little while ago and refilled the reservoir. Ever since then when I try to use it the fluid will spray out at full strength for maybe a second at the most and then just trickle out. If I try to immediatly use it again it will still just trickle out but if I leave it for a little while it will do the 1 second spray again.

There doesn't seem to be any obvious blockages in the nozzle and I can hear the pump.

Any ideas what could be wrong? Is the pump broken?

11

The blockage probably isn't in the nozzle, it's right at the inlet of the pump. Some have a screen, many don't.

You can wire the pump backwards temporarily, to run the pump in the other direction and hopefully push the blockage out of the pump's inlet. Or put compressed air into the outlet hose of the pump - the hose that leads to the nozzle. You can also remove the pump, and run it backwards with a source of clean water at the output. You can do this with a 9V battery. Make sure all the rubber lines are clear as well.

When you ran it out is likely when the pump sucked up some debris that had settled towards the bottom of the reservoir.

Check the reservoir for debris at the bottom. You might have to remove it to flush and wash it out thoroughly.

You could also replace the pump with a new "clean" one, but I hate spending money - and would rather spend an hour fixing it than spending $20 on a new pump. That's just me . . .

  • Sounds like a plan. I'll give that a go. – BunkerMentality May 7 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.