0

SOLVED

Any help appreciated!!

Both head lights are working as normal when on low beam. The moment I switch to high beam the left headlight goes to full and the right lamp goes out entirely. I've swapped the bulbs and the issue remains with the right head lamp.

I have driving lights attached to the right lamp and these no longer work either.

Many thanks in advance for any help,

Ben

  • Check all the wires / connections on the right hand headlight. – Solar Mike Apr 26 at 8:31
  • I've checked all the wires and they're all intact and working as far as I can tell. Could it be a circuit breaker or fuse or something? – Ben Apr 26 at 8:35
  • Could be many things, check from either end for supply, broken wires, blown fuse etc But be logical and don't jump about - that's how you miss something. – Solar Mike Apr 26 at 8:36
  • Main fuse was fine but fuse for individual light under the steering wheel had blown. Thanks for your help! – Ben Apr 26 at 9:43
  • Instead of editing your question with "solved" write your own answer with the information, then when you can, select it with the check mark to close the question ok n and actually let people know that way there is an answer which worked. That's how Stack Exchange works! – Pᴀᴜʟsᴛᴇʀ2 Apr 26 at 19:25
0

I would check all the wires that connect right headlight, then if there is nothing wrong, maybe see a electrical mechanic...

  • I've checked them as far as I can and they seem to be working. Could it be a circuit breaker or fuse? – Ben Apr 26 at 8:35
  • Maybe, check them too. – Eziooh Apr 26 at 8:39
  • It was an individual fuse under the steering wheel! Thanks for your help – Ben Apr 26 at 9:43
  • @Ben, you can answer your own question below! – Bob Cross May 26 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.