0

I had recently bought a 1998 Gen 3 Subaru legacy (BH5) with 190k Kms/ 118k Miles on it, for the first month it ran perfect with zero issues. Suddenly one day I started up the car as I was reversing out I could hear and feel the engine cylinders become more erratic and slow down until 3 seconds later the entire car died. I cranked the car again and then as if nothing happened I drove home without a hitch.

After the first incident, a few days later while I was driving it occurred again, the engine started to stutter, and would slowly die - prior to the engine going out 3-5 seconds before, the accelerator pedal would become unresponsive, no matter how far down I pushed there would be no acceleration at all as if I hasn't even touched the pedal. Then again after the car dies I restart and its usually normal again. These incidents would begin to occur more and more until a week later now it happens ~ every 2 days.

I found a video of my exact same car, this is a identical 1:1 of how the engine behaves, moves and sounds on mine (video at 0:50 - 1:30)

https://youtu.be/uUMFOQcvKtg?t=51

I checked the fuel fuse, it was fine but I replaced it anyways, had a battery and alternator check and they were fine. I took it to a mechanic who took it for an entire days test drive along roads and hill and it wouldn't play up even once. He checked the engine and said the sparks and leads were all good, he did a scan and it showed up with zero codes. so now I'm left wondering what it could be, my only guess is the fuel pump or filter has an issue as I'm told on many older cars they don't sensor codes for it - but when I suggested it to the mechanic he said probably not but didn't give a reason why and just said bring it in again.

Anybody have any thoughts on what might be going on?

  • Have you had your OBD codes read? What if anything was found? – GdD Apr 11 at 12:15
  • The mechanic just told me he "checked it for codes and there were no codes found" Starting to think he's juicing me for money, he charges $200 to test drive it around for a few minutes and opening the bonnet. The car didn't act up when he drove it and he didn't do anything to it but still charged me $200 – Mike Apr 11 at 19:59
  • Forgot to add, my dash doesn't indicate an issue, the check engine light is off when it drives fine, but will flash on for the duration of the engine stutter/stall – Mike Apr 11 at 20:25
0

Hmmm. Were you seeing a fuel related system, I'm pretty sure you'd see a check engine light and code for that model year car. The fact that you don't see codes tells me to start checking things that don't normally send out codes.

--Loose battery clamp or ground wire somewhere.
--Spark plug troubles / ignition wiring system ground out somewhere / ignition module issues. --Blockage in fresh air intake. --Vacuum leak somewhere.

Let us know what you find.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.