1

I put new brake lines in the car, put the fluid into tank and started bleeding the system. The problem is the pedal goes hard after a few pumps but gradually loses pressure and its not getting any better even when I already circulated almost 2 litres of brand new brake fluid through the system. I don't see any leaks and keep the reservoir always topped.

There's some hissing sound in the engine area when operating the pedal but I guess that's just air coming in and out of the brake booster?

I also put new seals into the master cylinder which fixed the leak between cylinder and brake booster but otherwise didn't help at all.

In the car there's also a hydraulic clutch and when there was a leak it was immediately evident. I fixed the leak and bled the clutch with no drama, but these brakes just refuse to operate properly.

Can someone please help? And if it's of any significance, the master cylinder was without fluid for half year while the car was disassembled. I suspect its just k.o. at this point, but there wasn't any corrosion or scratches when I disassembled it

  • I have same with my Elantra 2003 1.6gls. I change only rear lines. Brakes work for 2-3 days then same problem occurs. The hissing louder near ABS and at rear wheels. told to vent lines for many times. Not tried yet. – user46942 Mar 29 at 16:42
0

You nay find that you need to "pressure" bleed it (garages have that type of equipment) or just raise the front (or rear) depending how the master cylinder slopes to help push out the trapped air.

Bleeding with two people can be effective ie one person pushes on the pedal, the other opens the bleed valve then closes it - then the pedal is released... That way fluid does not travel "backwards" in the brake lines...

  • I already bled the brakes 3 times with 3 people and its still the same :( i guess going to mechanic shop will be the only option left – Martin Mar 29 at 9:51
  • You say you put new seals on the master cylinder due to a leak @Martin, I'd say your problem lies there. – GdD Mar 29 at 11:11
  • Probably yeah, the master cylinder, i just wanted to be more sure before i throw 150 bucks at it – Martin Mar 29 at 12:18
  • Did you bleed the master cylinder? It may not be a problem with o-rings, but simply the master cylinder needs to be bled. If you take a master cylinder apart, it must be bled. – Tim Nevins Aug 26 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.