2

Gents could use some help. Have an 03 f150 with a new 5.4 about 500 miles on it now. I had a po171 and 172 code and ended up doing a smoke test to find an injector 0 ring leaking and a vacuum leak at egr. Fuel trims in pic 1.

I fixed those and got code po406. When it set the code I saw fuel trims improved but it is still burning rich. I should mention I have not drove it since I fixed those leaks. Any ideas enter to go from here? Egr hold vacuum also and runs rough when vacuum is applied manually to egr valve when at idle. It does have a minor engine missenter image description hereenter image description here

  • First pic didn't have it but stft bank 1 was 7.0 ltft bank 1 was 29.7 stft bank 2 was 3.1 and ltft for bank 2 was 23.4. This was at 654 rpm. It had the po171 code – Yerg Feb 17 at 9:59
  • Welcome to Motor Vehicle Maintenance & Repair! Isn't the code reader showing there are 10 codes? If so, what are the other codes? – Pᴀᴜʟsᴛᴇʀ2 Feb 17 at 12:58
  • It has airbag codes from the previous owner that are seat belt tensioner and abs circuit and it had the p0171 and p0172 when I started messing with it. The 171 and 172 went away or never reset the only code showing was the p0406 code. Fuel was at 30 when tested at idle – Yerg Feb 19 at 2:47
  • EGR was removed and cleaned and I'm really thinking about the pressure feedback sensor as a culprit but I'm unsure – Yerg Feb 19 at 2:54
  • Anyone have any thoughts? Not alot of Info out there for the PO406 code. – Yerg Feb 19 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.