2

I recently had to replace my alternator as the one original to the car died after 180k miles. The new unit is a Subaru re-manufactured alternator purchased from the dealership.

The original failure of the alternator was confirmed by taking my car to a local place that could do charging system testing. It showed there was zero voltage being delivered by the alternator. After replacement, I had it retested and the voltage is great with minimal flutter.

The problem now is that the battery light remains lit on the dashboard.

Here's what I currently know and have tried:

  1. As mentioned above, a charging system test came back positive.
  2. Using an OBD2 scanner I show a good charge level.
  3. The battery is tested and is good.
  4. The brake and battery light are both lit, but I gather this is normal for this generation of Legacy.
  5. I can pull the 3-pin plug from the back of the alternator and the lights go out.
  6. There's no voltage coming from the sense pins on the alternator.
  7. Voltage across the 10A alternator fuse in the engine bay was 11.7V. Voltage at the top post of the alternator was 12.4V.

The one variable, and possible red herring, is that I've also just replaced all the incandescent wedge bulbs in the instrument cluster with equivalent LED units.

Another new twist is that there's an audible whine now coming from the new alternator. This developed after a short trip to a store about 5 minutes from my house. The belt is not over-tightened as there is a small amount of play in it.

Any ideas about how best to diagnose or check this would be very appreciated.

  • Check fuse 3 in the underhood fuse box, make sure you have charging voltage on pin 2 of the alt connector. If that's fine it's the alt. And probably make sure the alt is grounding through it's mounts. – Ben Feb 2 at 3:45
  • The fuses in the underhood box didn't have any numbering that I could see in the dark, but the 10A fuse corresponding to "ALT-S" was checked visually and with the continuity on the multimeter and it was good. There does appear to be ground between the alternator chassis and the mounting points, continuity tester gave me a beep at least. I then tested all three of the pins and there was no voltage there at all. So what could that mean? – Ajax Feb 2 at 4:40
  • possibly wiring, one pin will be power sense, one will be a field wire from the pcm, the last will be the lamp control. You should test for voltage drop across the alt-s fuse if that's ok then do a load test on the sense wire. As a test you can apply charging voltage to the sense pin with the connector still plugged into the alt. – Ben Feb 2 at 14:31
  • On testing the fuse would I simply remove the fuse and use the Multimeter to bridge the connection, then reading the resulting voltage? The other two I'm not as clear how to perform although I can find examples of how to load test a circuit online so that doesn't sound too hard. Finally, is it possible for the alternator to charge fine, but have a problem with the sense lines? – Ajax Feb 2 at 15:39
  • Did you check the battery itself? Alternator issues often cause battery issues. – PeteCon Feb 2 at 16:41
0

I couldn't figure this out and in frustration I took the car into one of our local repair shops. Thankfully they were able to troubleshoot and solve the issue and I'll share the knowledge gained by applying $100 to the problem.

As it turns out the LED bulb used for the Battery warning light was the source of the problem. The circuit that leads from the alternator sense wires to the warning light is more-or-less a straight line and apparently it's rather sensitive to resistance because the LED bulb added exactly too much. This in turn caused the warning light to remain lit even though the alternator was actually functioning normally. In the end, they simply replaced that one LED with a #37 incandescent wedge bulb and it worked again.

The rest of the LED bulbs used in the cluster are fine. I'm still not sure why I couldn't read any voltage off the sense pins, but I'm confident enough to say I'm likely part of the problem there. Hopefully this saves someone else some money.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.