1

I recently just had my valve cover gasket replaced due to an oil leak. for some odd reason, the red oil light now lights up on my dashboard. I wasn't due for an oil change til the end of this month but i went yesterday and got it done along w/ a engine flush. maybe i'm crazy but i thought that might help. apparently i was wrong because driving home today the light came on again. i'm not worried cuz i obviously got my oil change just yesterday. Do you guys think the oil pressure sensor is just faulty and i need it replaced? the shop told me if the light comes back on to just bring my car back to them and they'll clean the sensor at no charge. Car guru opinions would be appreciated. has anyone else had the oil light come on after getting the valve cover gaskets and spark plugs replaced? 2009 Mercury Mariner

side note: the light only comes on when i come to a stop. when i hit the gas, it disappears.

  • Have the sensor checked, also get the actual oil pressure checked by using an external gauge and the engine idle speed checked. – Solar Mike Jan 16 '19 at 5:59
  • How many miles/kilometers has the car done? – HandyHowie Jan 16 '19 at 8:18
  • around 155K miles. 09' Mercury Mariner – marinermercury Jan 16 '19 at 11:24
  • Is this the 4/6/8 cyl engine? – Pᴀᴜʟsᴛᴇʀ2 Jan 16 '19 at 14:23
  • 6 cyl engine. the oil light only started coming on after getting the valve cover gaskets replaced. not once did i see it when i had the actual oil leak. which is odd. – marinermercury Jan 16 '19 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.