1

Please help! I'm having this same issue on my Ford Focus 2013 SE. I drove 4 hours out to snowboard and 3 minutes away from the resort my car slows down and I rev the engine and the RPMs shoot up but the MPH never goes over 15 MPH.. I ended up having to leave it there parked somewhere hopefully safe and get a ride back because I worked the next morning and EVERY SIGNLE PLACE to get anything checked was closed till Monday. I even tried dealerships. I didn't know to check the fluid BUT I literally had my car in a shop for my oil and tires where they check all the fluids about a week before this happened, so my concern is for your knowledge of what to do after the fluid check. I also bought this car with a transmission warranty on it, it drove a little funny, I brought it to the dealership I bought it from and they "said" they fixed it. I believed them but it never really ever felt perfect just a bit better. About 2 years later is where we are from that and only about 30,000 more miles since I bought it. It also currently only has 70,000 on the mileage

  • 1
    Is this a standard shift or automatic transmission? I take it standard from the title? If so, most likely the clutch is bad. – Pᴀᴜʟsᴛᴇʀ2 Jan 9 at 3:06
  • It’s automatic and there’s no way of doing it manually either I’ve checked – Josh Jan 9 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.