0

A month ago, I changed my DSG auto 7-speed transmission's mechatronic because of another issue and after that everything was working just fine. Recently I found that when I start my car and switch my gear from P(parking) to D(drive), with the first gear D1 the car moves very slowly and the RPM doesn't increase that much unless I hit the gas pedal. It was not like that before. I am wondering what is the issue exactly and how can I fix it? Any response would really be appreciated. Thank you

  • Do you mean when you are just letting the car "creep" in D (i.e. not pressing the accelerator)? If so the current behavior sounds normal to me (and matches the behavior of my car with the same gearbox) – motosubatsu Jan 2 at 21:58
  • Yes, you are right @motosubatsu however the car used to move a bit faster after selecting D1 and not pressing the accelerator. Also when my car is parked on up the hill and try to move forward with selecting D1 gear with no acceleration, my car almost don't move and it started to backward unless I hit the accelerator pedal. Any suggestions? Thank you. – zakaria mahmud Jan 3 at 7:15
0

I assume you changed the DSG ATF when you changed your mechatronic. I would say its normal behavior for your car to shake or even go backwards on a hill sometimes as you aren't giving it any gas. The only time I've had problems with my VW CC creeping inconstantly is when I flushed my brakes, but it solved itself after a while. Have you changed your brake fluid recently?

  • Aha, No, the brake oil was changed more than 2 years ago. – zakaria mahmud Jan 4 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.