2

I noticed lately that on my dash engine heat goes close to hot but never really gets there. That usually happens when i am in idle. When i start driving it goes back to normal and only sometimes goes close to hot. I hope this is not water pump which might get pricey.
Any suggestions?

enter image description here


This is what the top of the radiator looks like. enter image description here

  • Welcome to Motor Vehicle Maintenance & Repair! First, ensure your coolant level is up to snuff. Second, ensure your fans are kicking on. This is usually a cause of overheating when stopped. Next, is the cooling system due for new Dexcool (150k miles/5 years old)? – Pᴀᴜʟsᴛᴇʀ2 Nov 4 '18 at 13:35
  • Coolant level looks ok in the white tank. Fans are definitely kicking in. I noticed that needle goes to borderline between normal and red but never goes into red. I know 2.5 years ago my engine was overheating amd timing cover was changed as well as coolant. I just opened the radiator cover and took a pic – Stribor K Nov 13 '18 at 3:02
  • @StriborK did you ever get this figured out? My first guess would be the (mechanical) thermostat (generally between the radiator and the water pump). Second guess for me would be the water pump. – Cullub Jun 10 at 15:50
  • I got 07 had same problem one of my fans wasn't turning on it was a problem in my circuit panel by the batt , after i bought after market fans from auto part store that aint crap but i change the radiator cause dexicool clogged it after a while especially if you aint using it right new water pump and thermo stat if yoi replace them with both fans running that should fix you problem ill start with radiator. – Alton Mckinney Jul 9 at 12:10
0

Ive owned 3 3800 powered vehicles. First thing you need to do is get rid of dexcool. Completely flush it out and refill with distilled water and add some preston cleaner or TSP drive the car for about 3 days then drain then refill with water idle until warm cool down drain. Then refill with green antifreeze and don't forget to bleed the system there is a small 8 mil bolt on top of the thermostat housing. Once you have this done change your thermostat to a 180 degree thermostat. You should see a cooler running car unless in stop in go traffic during this time it will still climb to 190. Also 04+ grand prixs do not have coolant temp sensors located on the radiator.

  • Thanks for the info here. Could you explain why the green is better than the orange? I hadn't heard that before. My first guess would be the thermostat as well. – Cullub Jun 10 at 15:49
0

This is perfectly normal in cars that actually idle (my last two vehicles have had idle stop/start system, and a hybrid system, respectively, so I haven't seen this behaviour in the last two vehicles).

When idling, there is no air current on the radiator. Thus, the system continuously heats up, until the radiator fan(s) kick in. The thermostat opens at usually bit below 90 degrees Celsius or so, which is the normal temperature of the engine when driving. However, the fan(s) kick in at much higher temperature, probably around 100 degrees Celsius or so.

Thus, you are close to the hot red zone when idling, but you never reach the hot red zone if everything is working properly.

When driving, the air current in the radiator ensures that radiator is adequately cooled even without fans rotating, and thus, the thermostat opening temperature (usually bit below 90 degrees Celsius or so) dictates the engine temperature.

If your engine temperature stays normal when driving at highway speeds for extended periods, your water pump and thermostat are probably working just fine. The engine temperature when driving at highway speeds fo extended periods should stay constant. If there's variation in the engine temperature (apart from asymptotically reaching the steady-state level), something's not right. A bouncing temperature reading at these speeds would be a cause of concern.

I would check the coolant level (please don't open the radiator cap when engine is hot!) and the tightness of the radiator cap (again, don't loosen it when engine is hot!), though. It buys you peace of mind to do this check, but it costs you practically nothing apart from few minutes of your time.

  • I would not say it is "normal" - it all depends on the accuracy (or lack of) of the temperature gauge, they are only an indicator and, quite often, are designed to exhibit a large movement for as small temperature rise above about 85 deg C while only a relatively small movement for 5 degrees to 80... the only way to be sure of what the temperature is is to use an accurate thermometer... – Solar Mike Jul 9 at 12:45
-1

yeah sometimes it's your coolant temperature sensor that's on the outside of the radiator maybe you could unscrew it clean it off and put it back in don't forget to put the white pipe dope around the threads additionally I think your coolant looks pretty funky it doesn't look very clear looking looks kind of cloudy you might want to change your coolant but it could just be that your temp sensors clogged with a bunch of junk around it so it's not very accurate?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.