I recently bought an ELM327 adapter from China and was very satisfied with it. It was working fine with Torque and other OBDII apps for Android, and I could always pair with it using 1234 as the bluetooth PIN code as soon as I plugged it in the car and turned on bluetooth.

After a little more than a month plugging it in after turning on the ignition and removing it after turning off, one day it just refused to accept the 1234 pin code, and since then it never accepted it anymore. I wonder if the bluetooth module might have been somehow reset or its memory corrupted in some way so the current password might have changed, but before I go out the trouble of making a little software to brute force crack the 4 digit pin I'd like to know if anyone ever had the same problem and, if so, whether it was possible to recover from it.

  • Tip: You don't have to remove the adapter if you drive the car every day. I also have one of the made in china adapters and it's been in my subaru for months. Still working and no problems with it or the car. Commented Feb 26, 2015 at 10:22
  • me too facing the same issue & I suspect the bluetooth module to be faulty & I am planning to repalce it with HC-05 module
    – Chetan
    Commented Mar 10, 2017 at 9:33

3 Answers 3


Try giving one of these pin's a try:

0000, 9999, 1234, 2345, 3456, 4567, 5678, 6789, 7890

Alternatively have you tried another phone, or a laptop with bluetooth and the appropriate software? Or even another car?

  • Yes Braunson, I have tried some of these and with the adapter on another car and through another phone and computer too, and none worked so far :/ I'd hope there would be some kind of reset procedure, but if I crack open the dongle to access the bluetooth module on top I guess it will probably break anyway. I'm traveling right now, but when I get back I'll try some more codes then I get back here telling if any of them worked. Thanks!
    – Claudio
    Commented May 21, 2013 at 17:19

When this happens it's usually due to the ELM module needing it's firmware reflashed. This involves removing it and reflashing the chip or simply replacing it. You can find more information about this at ftdichip.com they have a lot of DIYs on how to build these modules.

This breakage is very common when buying the cheap China built adapters.


The problem is not OBDII but the phone, the code is 1234. You have to go to settings then management applications then go on those running and then click on Bluetooth and forced shutdown.

NOTE: Original text below. Translated text above.

Il problema non è OBDII ma il telefono,il codice è 1234. Dovete andare in impostazioni poi su gestione applicazioni poi andate su quelle in esecuzione e poi su Bluetooth e cliccate su arresto forzato poi cliccate su svuota Cache e riavviate il terminale. Fate ora l'accoppiamento e vedrete che con il codice 1234 funzionerà.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .