2

i have a 2004 VW Golf 4 which misfire and brake loss of power. i have bunch of codes which i don't know how to go forward. the codes are; 18321, 18034, 18020, 18014, 17839, 17924, 16725, 17580, 17952. can anyone please show me the way forward in solving the problems

1

I don't have a specific solution for you, but gave you a list of things to check at the bottom of this post. You have codes indicating issues in 3 specific areas. Transmission, Brakes and Engine. I apologize for this going long.

Let's start with breaking down the fault codes and look for commonalities for your MK4. A quick internet search lead me to http://www.bentleypublishers.com/tech/vw/vw.dtc.table.htm. I found Volkswagen specific descriptions at autocodes.com

Not all DTCs were listed on the Bentley Publisher's site. I backfilled from https://sites.google.com/site/1810martin/fault-codes-18000---19999

Transmission

18034 P1626 Data-Bus Powertrain Missing Message from Transm.Contr. Possible causes

  • Transmission Control Module (TCM) incorrectly coded

18022 P1614 MIL Call-up Circ./Transm.Contr.Module Range/Performance

  • I was unable find anything concrete, but it is related to the Transmission Control Module.

Both of these could be caused by an installed tune. One OP on a forum had this happen with a switchable tune. In one position, P1614 would set and he had to have it reprogrammed to resolve it.

Brakes

18014 P1606 Rough Road Spec Engine Torque ABS-ECU Electrical Malfunction

  • I wan't able to find much on this one. One forum post where the OP had low system voltage (10volts under load). Charged the battery and was able to clear the code (temporarily until the battery discharged again). Did/do you have a low battery condition?

18321 P1913 Pressure Sensor for Brake Boost (G294), Short to Ground Possible causes:

  • Faulty Brake Servo Pressure Sensor
  • Brake Servo Pressure Sensor harness is open or shorted
  • Brake Servo Pressure Sensor circuit poor electrical connection

17839 P1431 Activation of brake vacuum pump, open or short to ground Possible causes:

  • Faulty Brake System Vacuum Pump
  • Brake System Vacuum Pump harness is open or shorted
  • Brake System Vacuum Pump circuit poor electrical connection

Engine

17924 P1516 Intake Manifold Changeover Valve circuit Open Possible causes:

  • Faulty Intake Manifold Changeover Valve
  • Intake Manifold Changeover Valve harness is open or shorted
  • Intake Manifold Changeover Valve circuit poor electrical connection

16725 P0341 Camshaft Pos.Sensor Circ Range/Performance Possible causes:

  • Faulty Camshaft Position Sensor
  • Camshaft Position Sensor harness is open or shorted
  • Camshaft Position Sensor circuit poor electrical connection
  • Faulty starter motor
  • Starting system circuit Dead (Weak) battery

17580 P1172 Throttle Actuation Potentiometer Sign.2 Signal too Low Possible causes:

  • Faulty Throttle Position Sensor (TPS)
  • Throttle Position Sensor (TPS) harness is open or shorted
  • Throttle Position Sensor (TPS) circuit poor electrical connection
  • Faulty Throttle Drive electric motor
  • Faulty Throttle Valve Control Module

17952 P1544 Throttle Actuation Potentiometer Signal too High Possible causes:

  • Faulty Throttle Valve Control Module
  • Faulty Throttle Actuator
  • Throttle Actuator harness is open or shorted
  • Throttle Actuator circuit poor electrical connection

One common theme is they mostly seem to be electrical, as in possible low voltage or bad ground(s). As it's an older car, the engine bay might be dirty. I would first clean it up to have good visibility, then I would check:

  • Battery voltage while idling and all accessories turned off. This should read above 13.6 volts, near 14.4 would be typical. If not, the likely culprit is the alternator.
  • Engine to chassis ground.
  • Battery to engine ground.
  • Worn/damaged wiring harness.

Additionally, verify your Camshaft Position Sensor is reading correctly. Incorrect readings will cause misfire and can be caused by a bad sensor. Also, if you have skipped a tooth on a timing chain you might receive this. This may require a scope and a backprobe to test properly.

For your transmission codes, you may have a tune that is bad. If you applied a tune, set it back to factory and see if the error clears. If you are factory, the TCU may need a re-flash or replace.

0

Charge or replace the battery and have the alternator tested for operation. Also check all of the earth straps and connectors of the wiring loom for corrosion and water ingress. I've seen any number of codes thrown by a modern Golf with a dead battery. There is a chance part of your wiring loom is full of water. Once you've sorted the voltage supply issue, the poor performance should vanish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.