The Problem: The RepairSolutions app has been switching back and forth between "Erasing Firmware… 0% completed" and "Upgrading Firmware… 0% completed" for more than half an hour.

What I Did: I just got an Innova Code Reader 3120f. I checked the codes on a vehicle, and installed and logged into Innova's RepairSolutions app on my Mac. When I plugged in the reader the software immediately said that there was a firmware update for it which I accepted.

What Can I Do? If I unplug it will it be broken forever, not broken at all, broken but able to be fixed with Windows? I know that disconnecting things while the firmware is being erased or updated often kills the device. It's been sitting here for a long time. It's been more than half an hour. I'm okay with leaving it longer, if it will work.

  • 1
    If you continue to have a problem then you should just get a hold of their support team.
    – Milison
    Aug 22 '18 at 12:03
  • Welcome to Motor Vehicle Maintenance & Repair!
    – Cullub
    Aug 22 '18 at 12:18
  • After about 3 hours I unplugged it and plugged it and it didn't work anymore. I plugged it back in again and the progress bar in RepairSolutions (which was still up on the screen from before) went a little crazy, jumping around instead of just going along. But that seemed promising. I'll try a windows machine.
    – timeSmith
    Aug 22 '18 at 13:33
  • Have the same problem. Cannot use the tool since the process was made with Mac or Windows environments. Any ideas?
    – Eddie
    Aug 26 '19 at 4:56
  • @Eddie What part of the firmware are you trying to update: "Boot loader," "Firmware," or "Database?" By the way, I did get mine fixed using the procedure in the answer below. The main takeaway for me was "If Windows isn't working try a Mac, if Mac isn't working try Windows. They seem to work differently."
    – timeSmith
    Aug 27 '19 at 11:56


  • Unplugging the device while the firmware update is happening, even if the update is frozen, may make the reader break. But the reader can then be fixed by plugging it into a computer that can successfully update the firmware.
  • If Windows isn't working try a Mac, if Mac isn't working try Windows. (they seem to work differently)

There are 3 different types of firmware on the reader. The "Firmware," "Boot loader," and "Database."

The one that first tried to run, and wasn't working, was the Boot loader. Unplugging the device while the firmware updater was running but frozen/looping did (temporarily) break the reader. Plugging the reader back into the Mac made the firmware updater finish, but it didn't actually succeed, and didn't fix the reader. Even though the reader wasn't working the computers (MacOS) would still recognize it and try to install the firmware. On Windows fixing the firmware didn't work at all, but on the mac after trying several times on two different computers it eventually worked.

After that there was another firmware update, this time for the Database. The Mac could not update the Database; it would take a long time progressing well and then stop with an error about one of the parts of the database. Windows was able to update the Database with no problem, even though it couldn't do the Boot loader at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.