2

I own a 2005 nissan xtrail with a 2.5L engine (QR25DE). I have problems with my vehicle,

  1. too much fuel consumption ( 3.8km/L ) My car has a 60Liter tank , my last fuel up gave me 229KM until the car fuel tank well completely dry; i had to refuel from a jerrycan as the engine went off somewhere far from the petrol station.

  2. I have loss of power, the car can't go more than 120km/h; and when i get to 80km/L to car struggles to get to a higher speed.

  3. I have problems with my catalyst as i hear rattling sounds coming out of the catalyst. I have the error code >> p0420 catalyst system efficiency below threshold

Please see below screenshots from torque pro app.

  1. Air fuel ratio

enter image description here

  1. Rich/lean test

enter image description here

  1. Vacuum reading

enter image description here

  1. 02 sensor Bank 1 Sensor 1 Graph

enter image description here

  1. 02 sensor Bank 1 Sensor 1 wide band voltage

enter image description here

What should i look for to fix the problem ?

  • 1
    I’m not sure about those o2s b1s1 graphs in picture 4. It should use an afr sensor and there’s no scaling. Can you confirm the afr voltage in the last picture with a dvom? Any exhaust leaks? How about b1s2 o2s voltage? How about fuel trim? Pic 1 shows a measured value but for which bank? – Ben Aug 16 '18 at 13:47
1

Hi I would the sensor after cat converter, the voltage should be 0.000>0.570 once in a while going to 0.750. If that’ok then I would check cat converter being blocked needs cleaned if possible or replace

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.